Incomplete bookmark file when running out of disk space

VERIFIED DUPLICATE of bug 86501

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 86501
16 years ago
13 years ago

People

(Reporter: Mike, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

I run out of disk space and mozilla wrote half my bookmarks in the file. Even
after I freed up some space, it kept writing the corrupted file.
When I exited mozilla there was available space on the disk, but the next time I
used it, the bookmarks were still incomplete.


Reproducible: Didn't try
Steps to Reproduce:
1.Run mozilla
2.Fill up the disk
3.Make it save the bookmarks
4.Close and reload mozilla to see incomplete bookmarks

Actual Results:  I lost half my saved bookmarks.

Expected Results:  I should see all my bookmarks.

Mozilla should check if there is available space for all the bookmark file and
then write it. Or better yet, when saving bookmarks write them to a new file
(not overwriting the old) and if all are written correctly, remove the older
bookmark file (or keep it for backup).

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 86501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.