Closed Bug 1588412 Opened 3 years ago Closed 3 years ago

nsHTTPChannel doesn't need to perform process-switching anymore

Categories

(Core :: Networking, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla72
Fission Milestone M4
Tracking Status
firefox72 --- fixed

People

(Reporter: pbone, Assigned: pbone)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [necko-triaged])

Attachments

(4 files)

The calls to onMayChangeProcess can be removed from nsHTTPChannel. they're dead code and are unused here.

Priority: -- → P3
Whiteboard: [necko-triaged]
Depends on: 1590959
Attachment #9100786 - Attachment description: Bug 1588412 - Fix grammer in comment r=mayhemer → Bug 1588412 - (part 1) Fix grammer in comment r=mayhemer

the URL moz://a redirects to mozilla's website, Because it redirects to
https we want to use documentchannel.

Depends on D49100

Attachment #9100787 - Attachment description: Bug 1588412 - Remove MayChangeProcess calls fron nsHttpChannel r=mayhemer,jya → Bug 1588412 - (part 3) Remove MayChangeProcess calls fron nsHttpChannel r=mayhemer,jya
Fission Milestone: ? → M4
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/595f252ef63d
(part 1) Fix grammer in comment r=mayhemer
https://hg.mozilla.org/integration/autoland/rev/e0e3a3390f76
(part 2) moz:// documents should use documentchannel r=mattwoodrow
https://hg.mozilla.org/integration/autoland/rev/55c0d49b821c
(part 3) Remove MayChangeProcess calls fron nsHttpChannel r=mayhemer
Keywords: leave-open

The already-landed patches contained a spelling error. This patch fixes it.

Hey mattwoodrow - was e0e3a3390f76 supposed to fix browsing to moz://a? Because I just pulled these patches down, and the redirect doesn't appear to be working... or is there something else I need to do in order to enable DocumentChannel process switching?

Flags: needinfo?(matt.woodrow)
Regressions: 1593545
Regressed by: 1593447
Keywords: regression

(In reply to Mike Conley (:mconley) (:⚙️) (Wayyyy behind on needinfos) from comment #7)

Hey mattwoodrow - was e0e3a3390f76 supposed to fix browsing to moz://a? Because I just pulled these patches down, and the redirect doesn't appear to be working... or is there something else I need to do in order to enable DocumentChannel process switching?

Replied in bug 1591942.

Flags: needinfo?(matt.woodrow)
Keywords: leave-open
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aafdd02eb30a
Fix a spelling error r=mattwoodrow
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Regressions: 1595284
Regressions: 1595881
Regressions: 1611907
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.