Closed Bug 1588503 Opened 3 years ago Closed 2 years ago

1.81 - 1.92% Base Content JS (linux64, macosx1014-64-shippable, windows10-64) regression on push 25ba54160c0aee63142e87bf06e67b92c89f566a (Wed October 9 2019)

Categories

(Toolkit :: Autocomplete, defect, P2)

defect

Tracking

()

RESOLVED FIXED
84 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- fixed

People

(Reporter: Bebe, Assigned: kmag)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Attachments

(1 file)

We have detected an awsy regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=25ba54160c0aee63142e87bf06e67b92c89f566a

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

2% Base Content JS macosx1014-64-shippable opt 4,055,838.67 -> 4,133,773.33
2% Base Content JS windows10-64 opt 4,118,246.67 -> 4,196,488.00
2% Base Content JS windows10-64-qr opt 4,118,140.00 -> 4,196,434.67
2% Base Content JS windows10-64-shippable opt 4,118,273.33 -> 4,196,434.67
2% Base Content JS windows10-64-shippable-qr opt 4,118,166.67 -> 4,196,461.33
2% Base Content JS windows10-64-shippable-qr opt 4,119,568.67 -> 4,196,485.33
2% Base Content JS linux64 opt 4,054,836.00 -> 4,128,557.33
2% Base Content JS linux64-qr opt 4,054,942.67 -> 4,128,808.00
2% Base Content JS linux64-shippable opt 4,055,232.00 -> 4,128,656.00
2% Base Content JS linux64-shippable-qr opt 4,055,285.33 -> 4,128,781.33

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=23452

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/AWSY/Tests

Blocks: 1578356
Component: Performance → Autocomplete
Flags: needinfo?(enndeakin)
Product: Testing → Toolkit
Regressed by: 1573836
Version: Version 3 → unspecified
Priority: -- → P2

This performance regression is caused because the AutoCompleteChild.jsm module is now being loaded at startup due to the actor needing a pageshow event listener to initialize autocomplete for a page, and we don't filter out the initial about:blank. The older framescript version presumably didn't apply to blank pages. The performance test here just starts up with a blank page. There is a discussion of why this was deemed acceptable at https://bugzilla.mozilla.org/show_bug.cgi?id=1584032#c3

Perhaps kmag can clarify if this is an issue we can just ignore or should find a solution for.

Flags: needinfo?(enndeakin) → needinfo?(kmaglione+bmo)
Blocks: 1592626
No longer blocks: 1592626
Assignee: nobody → kmaglione+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(kmaglione+bmo)
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ce2bd0dce32
Don't load AutoCompleteChild.jsm before necessary. r=NeilDeakin
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

== Change summary for alert #27340 (as of Sat, 24 Oct 2020 01:37:53 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
2% Base Content JS macosx1014-64-shippable 2,888,065.33 -> 2,820,602.00
2% Base Content JS windows10-64-shippable 2,885,350.67 -> 2,819,155.33
2% Base Content JS windows10-64-shippable-qr 2,886,648.00 -> 2,824,592.00
2% Base Content JS linux1804-64-shippable 2,881,540.00 -> 2,819,834.00
2% Base Content JS linux1804-64-shippable-qr 2,881,532.67 -> 2,819,850.67
2% Base Content JS windows7-32-shippable 2,265,130.67 -> 2,219,682.67

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=27340

== Change summary for alert #27341 (as of Sat, 24 Oct 2020 01:44:42 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
56% raptor-tp6-sheets-firefox-cold loadtime linux64-shippable 3,941.00 -> 1,727.25
50% raptor-tp6-sheets-firefox-cold loadtime linux64-shippable-qr webrender 3,635.17 -> 1,813.67
20% raptor-tp6-yahoo-news-firefox-cold loadtime windows10-64-shippable-qr webrender 1,813.88 -> 1,444.42
19% raptor-tp6-sheets-firefox-cold linux64-shippable 969.18 -> 786.79
16% raptor-tp6-sheets-firefox-cold linux64-shippable-qr webrender 1,014.26 -> 855.38

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=27341

Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.