Closed Bug 1588609 Opened 2 years ago Closed 2 years ago

not all Firefox in-content pages are dark if a dark theme is selected in Firefox

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1529323

People

(Reporter: designakt, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently when selecting the OS level dark mode all in-content pages turn dark.
When selecting the dark theme in Firefox only some turn dark however.
(see attachment for current inconsistency)

This should be consistent so people can expect Firefox to be dark when they select a dark mode - no matter how they select the dark theme.
All in-content pages should follow the same same logic. When Firefox is on default theme in-content pages should be following what the OS sets (light or dark), when the browser is set to a specific theme - all in-content pages should follow that by going light or dark. (not necessarily full following the color scheme but at least if light or dark)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1529323

Tim, Is there a way for us to ensure internal consistency among about pages without needing to answer the much harder question of web wide dark mode triggered by dark theme?
I can see how one might see this bug as a subset of the bigger question if about pages are considers websites. They are also part of Firefox which requires we ensure consistency - and that is not about how web pages work, but about how Firefox appears consistent to our users. Which is a questions that doesn't seem to be a dupe of he bug above.

Flags: needinfo?(ntim.bugs)

(In reply to Markus Jaritz [:designakt] (UX) from comment #2)

Tim, Is there a way for us to ensure internal consistency among about pages without needing to answer the much harder question of web wide dark mode triggered by dark theme?

Not easily, the current in-content dark mode entirely relies on the prefers-color-scheme feature. about:newtab uses a different mechanism since themes can put custom background colors. The customize mode is technically part of the browser UI, so it's styled directly by the browser CSS.

Easiest path forward engineering-wise would be to fix bug 1529323. Using the same mechanism as the customize mode or about:newtab is unfortunately not as trivial. Bug 1529323 shouldn't be this controversial honestly, it's just a matter of figuring out small details and finding platform engineers to work on it.

Flags: needinfo?(ntim.bugs)
Duplicate of this bug: 1590407
You need to log in before you can comment on or make changes to this bug.