Closed Bug 1588728 Opened Last month Closed Last month

JS Error `this._highlightedNodeFront is undefined` occurs when hovering over nodes when picking from the Browser Toolbox

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox-esr68 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 wontfix, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: pbro, Assigned: gl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps:

  • Latest nightly,
  • open devtools,
  • open the Browser Toolbox,
  • click on the picker icon,
  • focus the browser window
  • hover over nodes in the browser UI and in the DevTools UI.

I don't exactly know when this occurs yet, but at some stage a JS error occurs:

JavaScript error: resource://devtools/client/inspector/markup/markup.js, line 725: TypeError: this._highlightedNodeFront is undefined

The stack trace for this is:

console.trace: 
resource://devtools/client/inspector/markup/markup.js 723 _hideBoxModel
resource://devtools/client/inspector/markup/markup.js 684 _onMouseOut

So it looks like on mouse out, there are now cases where this._highlightedNodeFront was not set.

Marking this as a small regression of bug 1568157 (which introduced this variable) because there wasn't any JS errors before.

This error seems easy to silence, we should probably just check if the variable exists before attempting to hide the highlighter, and bail out if it doesn't.

Assignee: nobody → gl
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30190859b9f5
Add a check for this._highlightedNodeFront in _hideBoxModel. r=pbro
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.