Closed Bug 1588785 Opened 28 days ago Closed 24 days ago

Turning OFF separate Private Browsing UI does not go back to default engine

Categories

(Firefox :: Search, defect, P2)

71 Branch
Desktop
All
defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.4 - Oct 14 - 20
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: pablo.muir, Assigned: standard8)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

[Description:]
When i enable separatePrivateDefault and set different search engines for normal and private mode, and then i dissable separatePrivateDefault, the private mode engine stays and does not revert back

[Steps to reproduce:]

Launch FF latest nightly
turn on browser.search.separatePrivateDefault.ui.enabled on about:config
Set BING for NORMAL search engine
Set AMAZON for PRIVATE browsing mode
Turn FALSE browser.search.separatePrivateDefault.ui.enabled in about:config

[Actual results]:
Amazon stays as private browsing search engine

[Expected results:]
Should revert back to Bing when doing a private search

TESTED ON:

Windows 10 64bit with latest nightly release
Ubuntu 18.04 64bit
MacOS 10.14

You are only disabling the UI pref, that hides the UI but doesn't change the feature settings, for that you should set browser.search.separatePrivateDefault to false.
The ui pref is only there to enable/disable the ui across channels. Though, this may still be a good idea to evaluate.

We should probably do this though, in case we decide to backout the feature via the pref. We don't want to leave people stranded with a setting they can't change except via about:config.

I also need to check if someone sets browser.search.separatePrivateDefault to false if we send out a notification and update any open private windows.

Assignee: nobody → standard8
Priority: -- → P2

Try pushes are currently orange, but I think this is due to needing bug 1588756 - I'll re-push them tomorrow to make sure.

Iteration: --- → 71.4 - Oct 14 - 20
Points: --- → 3
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a4afa268baf
Send a notification when separate private default is toggled. r=mak
https://hg.mozilla.org/integration/autoland/rev/6ad4b26b21d7
Make the search service also detect when the UI is not enabled. r=mak

This seems to be some weird race condition that I've worked around by not waiting for the popup hide - we don't need to anyway as we've now got the default engine notification that we're checking.

Flags: needinfo?(standard8)
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba5b0986c9f1
Send a notification when separate private default is toggled. r=mak
https://hg.mozilla.org/integration/autoland/rev/46dc34915a75
Make the search service also detect when the UI is not enabled. r=mak
Status: NEW → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Not a regression because it was part of a new implementation.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.