Closed Bug 1588798 Opened 5 years ago Closed 5 years ago

Address bar is focused on startup in kiosk mode

Categories

(Firefox :: General, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 - unaffected
firefox72 --- unaffected

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image Kiosk mode screenshot

STR:

  1. Start Nightly with --kiosk command line parameter.
  2. Note the top edge of the screen.

The expanded Megabar can be seen intruding into the page.

The address bar being focused in the first place seems like a kiosk mode bug.

No longer blocks: urlbar-update-1
Component: Address Bar → General
Summary: Expanded Megabar intrudes on top edge of screen in kiosk mode → Address bar is focused on stratup in kiosk mode

[Tracking Requested - why for this release]: I imagine this is a big enough flaw to block kiosk mode shipping.

Blocks: 158968

There's a separate bug to prevent focus from going to chrome in fullscreen/kiosk mode, but the reason this isn't a blocker is because kiosk mode isn't typically used without setting a homepage as well.

If a user has gotten to the new tab page, they can break out of the kiosk mode (settings in the upper right).

Summary: Address bar is focused on stratup in kiosk mode → Address bar is focused on startup in kiosk mode
Priority: -- → P3

Changing the priority to p2 as the bug is tracked by a release manager for the current nightly.
See What Do You Triage for more information

Priority: P3 → P2

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

:ke5trel, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(ke5trel)
Flags: needinfo?(ke5trel)
Keywords: regression

Megabar is not activated in 71 so this shouldn't block shipping --kiosk in 71, untracking for 71.

The recent megabar updates may have fixed that on 72, bogdan could your team check if this bug is still valid with the megabar activated? Thanks

Flags: needinfo?(bogdan.maris)

Hi, This issue does not occur in Beta 71.0b4 or in our latest Nightly build 72.0a1 (2019-10-27). I will update the flags.

Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(bogdan.maris)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: