Closed Bug 1588830 Opened 2 years ago Closed 2 months ago

Replace sweep methods with traceWeakEdges in WeakMap

Categories

(Core :: JavaScript: GC, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: allstars.chh, Assigned: jonco)

References

Details

Attachments

(1 file)

In bug 1573809 Part 1 I was going to land the tracing for weak references in WeakMap, however it got backout in https://bugzilla.mozilla.org/show_bug.cgi?id=1573809#c12
Unfortunately I cannot fix that in time, so I split that as a separate bug.

The bug seems 100% reproducible on try but I cannot reproduce it locally on my ubuntu.

There are some pernosco links
https://pernos.co/debug/b21yQsiYWmitL6UcUN9a6Q/index.html#f{m[BPWo,AA_,t[AQ,B2k_,f{e[BPWm,B8oS_,s{af4hZQtAA,bASA,oB+BiXw,uB9JgAw___

Summary: tracing weak refererence in WeakMap → Replace sweep methods with traceWeakEdges in WeakMap

This refactors some of the code to remove indirection from Zone methods to
WeakMapBase where it's simpler just to implement the method on Zone.

Depends on D128351

Assignee: nobody → jcoppeard
Status: NEW → ASSIGNED
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/866c9884e63b
Use TraceWeakEdge for tracing WeakMap keys r=sfink
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.