Closed Bug 1588837 Opened 11 months ago Closed 11 months ago

Disable WebRender on some older Intel devices

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox70 + fixed
firefox71 --- wontfix

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Details

Attachments

(1 file)

This is a risk mitigation that would be super nice to get into 70.

Comment on attachment 9101311 [details]
Bug 1588837. Disable WebRender on some older Intel devices.

Beta/Release Uplift Approval Request

  • User impact if declined: We'll run WebRender on some machines where it doesn't run that great.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This just removes some device ids. It should be basically 0 risk.
  • String changes made/needed:
Attachment #9101311 - Flags: approval-mozilla-release?

[Tracking Requested - why for this release]: Reduce WebRender Intel risk

One of the big motivations for this is bug 1576637.

Discussed with jeff, we don't want to land this on m-c because we want to keep seeing issues from affected users in nightly.

Comment on attachment 9101311 [details]
Bug 1588837. Disable WebRender on some older Intel devices.

OK for uplift to m-r, we'd like to block WR for particular drivers.

Attachment #9101311 - Flags: approval-mozilla-release? → approval-mozilla-release+
Assignee: nobody → jmuizelaar

Based on comment 7, I am marking this issue as fixed.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.