Closed Bug 1588867 Opened Last month Closed Last month

Remove support for the carbon plugin api in SeaMonkey

Categories

(SeaMonkey :: General, enhancement)

All
macOS
enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

This carbon NPAPI parrot is dead. Frontend support in Firefox was removed long ago in Bug 850925

[Approval Request Comment]
Regression caused by (bug #): 850925 (ancient times)
User impact if declined: none dead code
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: some removals but goes into all current trees.

Attachment #9101357 - Flags: review?(iann_bugzilla)
Attachment #9101357 - Flags: approval-comm-release?
Attachment #9101357 - Flags: approval-comm-esr60?
Comment on attachment 9101357 [details] [diff] [review]
1588867-carbon-plugin.patch

[Triage Comment]
You also need to do the linux css - https://dxr.mozilla.org/comm-esr60/source/suite/themes/classic/linux/communicator/communicator.css#178
r/a=me with that sorted
Attachment #9101357 - Flags: review?(iann_bugzilla)
Attachment #9101357 - Flags: review+
Attachment #9101357 - Flags: approval-comm-release?
Attachment #9101357 - Flags: approval-comm-release+
Attachment #9101357 - Flags: approval-comm-esr60?
Attachment #9101357 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/6bd51ba5b088
Remove support for the carbon plugin api in SeaMonkey. r=IanN

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.