Closed Bug 1588875 Opened 2 years ago Closed 2 years ago

Unify OS detection in SeaMonkey

Categories

(SeaMonkey :: OS Integration, enhancement)

All
macOS
enhancement
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.63 wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.63 --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file, 1 obsolete file)

SeaMonkey uses a 100 ways to find out which OS/build is in use. Using Appconstants.platform seems to be the most inexpensive and/or common way to do it right.

See Bug 1228655 "Replace #ifdefs in browser code by AppConstants".

Attached patch 1588875-detectos.patch (obsolete) — Splinter Review

Tested in 2.53.

Attachment #9102841 - Flags: review?(iann_bugzilla)
Attachment #9102841 - Flags: approval-comm-release?
Attachment #9102841 - Flags: approval-comm-esr60?
Comment on attachment 9102841 [details] [diff] [review]
1588875-detectos.patch

[Triage Comment]
r/a=me
Attachment #9102841 - Flags: review?(iann_bugzilla)
Attachment #9102841 - Flags: review+
Attachment #9102841 - Flags: approval-comm-release?
Attachment #9102841 - Flags: approval-comm-release+
Attachment #9102841 - Flags: approval-comm-esr60?
Attachment #9102841 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/33f38b1be661
Detect OS using AppConstants.platform. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

V2 as discussed on irc was pushed. Basically use only ChromeUitls.Import for AppConstants.jsm.

r/a+ from IanN retained.

Attachment #9102841 - Attachment is obsolete: true
Attachment #9105399 - Flags: review+
Attachment #9105399 - Flags: approval-comm-release+
Attachment #9105399 - Flags: approval-comm-esr60+
Duplicate of this bug: 1160782
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.