Closed Bug 1588899 Opened Last month Closed Last month

browser_trackingUI_cookies_subview.js fails with DocumentChannel

Categories

(Core :: Networking: Cookies, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

Details

Attachments

(2 files)

Looks like this regressed recently, and now fails when we enabled DocumentChannel.

This is where it should have been in the first place. Those attributes belong there.

Attachment #9101378 - Attachment description: Bug 1588899 - Make HTTP classification flags available to DocumentChannelChild, since we use them to determine which content blocking events to fire. r?nika → Bug 1588899 - P2. Make HTTP classification flags available to DocumentChannelChild, since we use them to determine which content blocking events to fire. r?nika
Blocks: 1583700
Status: NEW → ASSIGNED
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2df73fda468
P1. Move classification flags related method to nsIClassifiedChannel. r=Ehsan,baku
https://hg.mozilla.org/integration/autoland/rev/5f75bd13473c
P2. Make HTTP classification flags available to DocumentChannelChild, since we use them to determine which content blocking events to fire. r=baku,Ehsan
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Depends on: 1589954
Regressions: 1590214

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.