Closed Bug 1588970 Opened 4 months ago Closed 4 months ago

Stop address book UI reporting many errors

Categories

(MailNews Core :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

Opening the address book causes these console messages to happen many times:

JavaScript error: , line 0: uncaught exception: 2147500033
JavaScript error: , line 0: uncaught exception: 2147746065

One is caused by not implementing nsIAbCard.generateChatName, and the other isn't an error at all, it's just NS_ERROR_NOT_AVAILABLE (the correct response) crossing the XPCOM boundary.

Attachment #9101443 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9101443 [details] [diff] [review]
1588970-addrbook-errors-1.diff

Review of attachment 9101443 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9101443 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/14258a1ca363
Stop address book UI reporting many errors. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.