theme rendered incorrectly

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: tobias, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104 (1.1b)

im was using the orbit theme for quite a while when suddenly the startup times
for mozilla became more and more longer. my profile is lcoated somewhere on
another computer in the lan. sometimes this resulted in a very strangely
rendered theme (see screenshot) - a mixture of orbit and classic theme.

Reproducible: Sometimes
Steps to Reproduce:
1.start mozilla
2.
3.

Actual Results:  theme mixture (orbit&classic)

Expected Results:  render theme correctly

to bypass this problem i created a new profile copied the
mails/bookmarks/themes... from the old profile to the new one and it worked again.
(Reporter)

Comment 1

16 years ago
Created attachment 92421 [details]
theme mixture

after a long startup time this innovative theme appeared

Comment 2

16 years ago
The build in the screenshot is a build from early June, and not the one you seem
to report the bug with. Can you please repeat which build you are seeing the bug
with.
Also, is the Orbit theme version you are using compatible with the Mozilla
version you are using?
(Reporter)

Comment 4

16 years ago
as far as i know the orbit theme is compatible. it say 1.0rc and the xul
interface hasnt change since 1.0 has it? so it should be compatible and it
actually worked more than once...
unfortunately i cannot reproduce the bug. loading the "corrupt" profile with
1.1b results and several other misbehaviours:
1. mozilla ending up in an endless loop (no window nothing; only about 12mb
allocated)
2. error window claiming "error launching browser window:no XBL binding for
browser" (plain window/white background and black font)
3. some kind of theme download window (again plain window with black text on
white background)
4. a whole bunch of little windows (rather a titlebar than a window)
now the 4th behaviour seems to be repeated each time i start the browser with
the "corrupt" profile.

Comment 5

16 years ago
There is an older bug about theme mixture occuring if the Mozilla profile is
shared with a Netscape 6.*/7* installation. Could that be the culprit here?
(Reporter)

Comment 6

16 years ago
probably not. i had installed nn6 quite a long time ago but i think i used
another profile for it.

Comment 7

15 years ago
reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 8

15 years ago
i started mozilla with the corrupt profile with 1.2a and it still didnt work
(the xbl binding message occured (see comment #4). i installed 1.2b afterwards
and mozilla started up with the corrupt profile quite fast (normal duration).
nevertheless the mail window could not be invoked/shown.
shall i still mark it as worksforme and file a new bug?

Comment 9

15 years ago
thanks for the response. if it works when not using the corrupt profile, then
there isn't a bug here. the bug would have been whatever screwed up the profile
in the first place.  failures when using a corrupt profile are not bugs. sounds
like this should be WORKSFORME.
(Reporter)

Comment 10

15 years ago
i have encountered quite a lot corrupted profiles and in my oppinion the fault
prevention is still too bad (though its getting better). i dont know if there is
one but for example there should be a version control of the profiles which
might ease the problem!?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.