If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't attach files from home directory!!

VERIFIED DUPLICATE of bug 147075

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 147075
15 years ago
9 years ago

People

(Reporter: amy smolens, Assigned: Scott MacGregor)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Hi -
I just switched from Netscape 4.7 to Mozilla 1.0 because I upgraded to Mac OS X.
I have had many problems and issues with things that are different (and worse)
than they were with Netscape 4.7, despite the fact that I have supposedly
"upgraded."
I have found one huge problem: I am unable to send text/document/photo
attachments from my home directory!!! When I try to do that what comes up in the
attachment window looks like a URL that says
file:///AmyX/Users/calamari/Documents... etc. That is the path of the attached
file, instead of the attached file itself. When I drag the file onto the desktop
and attach it from the desktop it works, but I shouldn't have to do that. This
is a big problem (among the many little ones...) Help!!
I would like to continue to use Mozilla, but there are so many problems I don't
know what to do. When do you expect to have an updated version that is rid of
these bugs?
I look forward to hearing from you soon.
Sincerely,
Amy Smolens

Comment 1

15 years ago
Amy,

When file is in your home folder and you attach and and the URL comes up are you
able to send you email? You may want to download a mozilla 1.0.1 build or
mozilla 1.1b build.

You also may want to check out the mozilla mac os x mozilla news group on
'news.mozilla.org'

BTW works for me with build 2002072208 

Comment 2

15 years ago
Amy, this problem could be due to the name of the file or a folder that contains
it having a special character in it, such as a slash or a colon. (Probably in a
folder name since you can put the file on the desktop and attach it successfully.)

Can you check for any such punctuation and let us know if you find any?

(Possible duplicate of bug 147075.)

Comment 3

15 years ago
Created attachment 92615 [details]
Email from amy

Attatching email I received from Amy...

Comment 4

15 years ago
I doubt Amy's problem is due to special characters in the file name. Logically
the problem would not disappear moving the file to the Desktop. On the other
hand it does seem strange the problem only occurs when the file is in the home
directory. Based on the URL of the file in question and where the file is
reported to exist, might the attached file be an alias? In addition, might this
be an IMAP problem or could this be an issue from converting NS4.x profiles to a
Mozilla profile?

Amy, I think it would be a good idea to see if the current ‘released’ version
exhibits the behavior. Amy you could download Mozilla 1.1b (b for beta) from
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.1b/mozilla-macosX-11b.smi.bin

Comment 5

15 years ago
looks like I was wrong, it happens :)
(Reporter)

Comment 6

15 years ago
The reason was due to a "slash" in the folder (not the file) name. Although Mac
recognizes slashes, colons, cyrillic characters, etc in the folder names and
Netscape 4.7 did, too, I guess Mozilla did not and was tripping over those
characters (slashes, colons, cyrillic characters.) I hope this is fixed, but if
you take your odd characters out of the folder names, at least you can attach
your items.

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 147075 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.