Closed Bug 1589141 Opened 2 years ago Closed 2 years ago

Add a check to ensure that page-load tests are using the mitmproxy recordings

Categories

(Testing :: Raptor, enhancement, P1)

Version 3
enhancement

Tracking

(firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: rwood, Assigned: Bebe)

References

Details

Attachments

(1 file, 1 obsolete file)

If for some reason there is an issue with mozproxy locally or in production, and a raptor-browsertime page-load test runs but uses live-sites instead of the recorded page (and use_live_sites was not set to true in the test INI) then we should fail the tp6 test.

:tarek, :bebe: Any suggestions on how we can do this? Are there specific mozproxy log messages that exist now that only happen when sites are being played back and not loaded live, that the raptor framework could troll for or something? Or maybe a new mozproxy method that we could query?

Flags: needinfo?(tarek)
Flags: needinfo?(fstrugariu)

would making a request to a specific URL do the trick?

We can implement a custom response in mitm

Flags: needinfo?(fstrugariu) → needinfo?(rwood)

(In reply to Florin Strugariu [:Bebe] (needinfo me) from comment #2)

would making a request to a specific URL do the trick?

We can implement a custom response in mitm

Interesting idea! Not sure - we wouldn't want to do or load anything that would destroy the 'cold' state of the browser before a page-load...

Flags: needinfo?(rwood)

I am confused, what happened exactly? If we set mitmproxy and have firefox calling it, why would it ever use live sites?

Notice that there's also the server_replay_kill_extra option to avoid calling extra servers.

Flags: needinfo?(tarek) → needinfo?(rwood)

:sparky had mentioned on slack that he was running raptor locally and it was using live sites (but shouldn't have been); and he noticed that he had some left-over/extra mitmproxy processes still running. After he killed those processes and tried again then it ran using the site playback instead. Did I capture that correctly :sparky?

Flags: needinfo?(rwood) → needinfo?(gmierz2)

:rwood, yup, that's right.

Flags: needinfo?(gmierz2)
Priority: P1 → P2

Bebe: do you have any further thoughts on this? Does mitmproxy add any headers or trace that we might be able to use to verify that it's in use? Can someone from the team pick this up and look into it?

Flags: needinfo?(fstrugariu)

Mitm should not add any headers or other thing to the traffic.
As suggested above a simple custom request to the proxy that will confirm it is working should e enough.

I will add a patch.

Flags: needinfo?(fstrugariu)
Assignee: nobody → fstrugariu
Status: NEW → ASSIGNED
Priority: P2 → P1
Depends on: 1585680
Duplicate of this bug: 1548576
Attachment #9125840 - Attachment is obsolete: true
Pushed by fstrugariu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6087761be5f5
Add a check to ensure that page-load tests are using the mitmproxy recordings r=tarek
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.