Closed Bug 1589266 Opened Last month Closed 29 days ago

Fix and enable test_ext_new_tab_processType.html with Fission

Categories

(WebExtensions :: General, defect, P2)

defect

Tracking

(Fission Milestone:M4, firefox71 fixed)

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: Tomislav, Assigned: Tomislav)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This test involves 3 different processes with fission, which is one too many to be easily handled with a mochitest. Could convert it to a browser or an xpcshell test, or just reuse the mochi.test process. Since the thing we're interested in testing only cares about window opening working across process switches, the third approach is good enough.

Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fcf2e9fabd1b
Fix test_ext_new_tab_processType.html with fission r=rpl
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

If this ticket already has automated tests and requires no manual testing, please set the " qe-verify" flag . If not, please provide steps to reproduce.
Thank you.

Flags: needinfo?(tomica)
Flags: needinfo?(tomica) → qe-verify-

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.