Closed Bug 1589324 Opened 4 months ago Closed 4 months ago

Website addresses and passwords strings that are exceeding ~70 characters are no longer truncated

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: simona.rosu, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached video NotTruncated.mp4

[Notes]:

  • Also, if you are logged to “Firefox Sync”, the Mobile Promotion will be wrongly displayed with the same width as the login’s title.

[Affected versions]:

  • Latest Firefox Nightly 71.0a1 (Build ID: 20191016212918) (64-bit)

[Affected Platforms]:

  • Mac 10.14
  • Windows 10 x64
  • Ubuntu 16.04 x64.

[Prerequisites]:

  • Have a saved login with a password/website address containing more than 70 characters.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to the “about:logins” page.
  3. Click the saved login from prerequisites.
  4. Observe the login’s elements.

[Expected result]:

  • The website address and password strings are truncated and the “Edit”, “Delete”, “Show Password” and “Copy” buttons are correctly displayed.

[Actual result]:

  • The website address and password strings are not truncated and the “Edit”, “Delete”, “Show Password” and “Copy” buttons are displaced.

[Regression]

  • The issue is not reproducible with older Nightly 71.0a1 builds. Considering this, using mozregression tool I have found the issue that broke this in the latest Nightly build. Here are the results:
  • Pushlog: https://tinyurl.com/y4bkltks
  • Last good revision: e3a8a694bfad19d0d6e9d3fb0a0bbf4caa3bb43d
  • First bad revision: cb426a0d94846dc8645183b25a3a23f66f473a82

From this pushlog it seems that bug 1588046 introduced this behavior.

[Additional Notes]:

  • Attached a screen recording with the issue.

Jared, your patch in bug 1588046 seems to have caused this regression, could you have a look please? Thanks

Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Priority: -- → P3
Attachment #9101963 - Attachment description: Bug 1589324 - Limit the width of the header and form to 700px wide. r?sfoster → Bug 1589324 - Restore max-width on .container. r=jaws,sfoster
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bac89dc0731a
Restore max-width on .container. r=jaws
Assignee: jaws → ntim.bugs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20191020214712) on Windows 10 x64, Mac 10.14, Ubuntu 16.04 x64.

  • The website address and password strings are truncated and the “Edit”, “Delete”, “Show Password” and “Copy” buttons are correctly displayed.
  • Also, the Mobile Promotion is correctly displayed if you are logged to “Firefox Sync”.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.