Closed Bug 1589391 Opened 5 years ago Closed 3 years ago

Download Panel doesn't show progress bar in high contrast

Categories

(Firefox :: Downloads Panel, defect, P3)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
97 Branch
Accessibility Severity s2
Tracking Status
firefox71 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox97 --- verified
firefox98 --- verified

People

(Reporter: florencia.diciocco, Assigned: molly)

References

(Blocks 2 open bugs)

Details

(Keywords: access)

Attachments

(2 files, 1 obsolete file)

Attached image download.png

Steps to reproduce:

Have High contrast activated
Launch Firefox.
Start a large download.
The download is in progress.
Open the Downloads Panel (about:download).

Actual results:

The progress bar cannot be seen because it's the same colour as the background. I tried to do a MozRegression but went as far back as version 66 (December 2018) and it seems it's always been like this.

Expected results:

The progress bar should be in another colour.

Component: Theme → Downloads Panel

If someone would like to contribute a patch for this, it would be welcome.
It looks like it's an old bug, so not an high priority for now.

Priority: -- → P3
Keywords: access
Whiteboard: [access-p2]

This issue still occurs on Win 10 aarch64 on Nightly 74.0a1(2020-02-04)

Updating the Accessibility Team's impact assessment to conform with the new triage guidelines. See https://wiki.mozilla.org/Accessibility/Triage for descriptions of these whiteboard flags.

Whiteboard: [access-p2] → [access-s3]

This is partially fixed. It looks like the progress bar is no longer the same color as the background color, but only if the download item isn't hovered over.

Assignee: nobody → yingjunj
Status: NEW → ASSIGNED
Attachment #9243348 - Attachment is obsolete: true

thanks for fixing this 😀 apologies for the duplicate bug!

Whiteboard: [access-s3] → [access-s2]
See Also: → 1733587
Attachment #9244847 - Attachment description: Bug 1589391 - Download Panel doesn't show progress bar in high contrast. r=mhowell,mtigley → Bug 1589391 - Make download progress bars visible in Windows high-contrast. r=Gijs,Itiel
Assignee: yingjunj → mhowell
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d676dd2a845f
Make download progress bars visible in Windows high-contrast. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
Blocks: 1733587
See Also: 1733587
Flags: qe-verify+

I able to reproduce the issue on Win10, using build 71.0a1 (20191017215425), using steps from description.
Verified as fixed on Win10/ Ubuntu 20.4 / Mac 11.6.2 using builds 97.0b7(20220123185805) and 98.0b1(20220124214229).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Accessibility Severity: --- → s2
Whiteboard: [access-s2]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: