Closed Bug 1589617 Opened Last month Closed Last month

Inspector Search captures CtrlOrCmd+F even when the inspector is not the selected panel

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

Attachments

(1 file)

STRs:

  • open devtools
  • select inspector
  • select console
  • use CtrlOrCmd+F

Expected result: the Console filter out put should be selected
Actual result: nothing happens in the Console UI, but if you focus the inspector, the Inspector search is focused.

It seems the inspector search shortcut overrides other cmd+F shortcuts in DevTools.

Initially thought this was related to using a frame with type=content or a <browser> element for the toolbox, but it seems to still occur with devtools.toolbox.content-frame=false. Might still be related to the changes we did around this, patches in Bug 1539979, changed the way we listen to our shortcuts.

Actually the issue is already in release, so it sounds like this is an old bug!

Using cmd+F in the Console/Debugger after using the inspector will be caught by inspector code and will not show the panel's search ui.

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e524c0d26f03
Stop catching search shortcuts from other panels in the Inspector r=gl,fvsch
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.