Closed Bug 1589620 Opened 1 year ago Closed 11 months ago

[Megabar] Opening a new window makes the Input Bar flicker on the left/right side

Categories

(Firefox :: Address Bar, defect, P3)

defect
Points:
5

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- disabled
firefox73 --- unaffected
firefox74 --- unaffected

People

(Reporter: mehmet.sahin, Unassigned)

References

Details

Attachments

(1 file)

788.15 KB, video/quicktime
Details
Attached video Screencast.mov

Nightly 71.0a1 (2019-10-17) (64-Bit)

1.) Start Firefox or open a new Window

Actual: The Input Bar flickers on the left/right side.

Expected: No flicker. To see a smooth expanding animation.

Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 72.1 - Oct 21 - Nov 3
Points: --- → 3

(In reply to Mehmet from comment #0)

Expected: No flicker. To see a smooth expanding animation.

Actually I think we don't want the animation in that case, so this bug is a bit backwards. Ideally we don't want any state change at all, i.e. the megabar should be expanded for the first paint already, but that's not currently possible without flushing layout which we don't want.

Assignee: dao+bmo → nobody
Status: ASSIGNED → NEW
Iteration: 72.1 - Oct 21 - Nov 3 → ---
Points: 3 → ---
Priority: P3 → --
Priority: -- → P3
Points: --- → 5
Environments: Mac 10.15, Ubuntu 16.04, Windows 10

Testing on Nightly74(2020-01-13) and Beta 73.0b4 (browser.urlbr.update1 =true) doesn't reproduce the reported problem anymore. I've recorded multiple new-window test scenario @ 60 fps, then replayed it at 15 fps and it looks like we open the new-window with the megabar already expanded for the first paint.

There is the megabar close animation when the next new-window is triggered, but IMO that would be expected functionality.

Status: NEW → RESOLVED
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Closed: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.