Open Bug 1589629 Opened 3 months ago Updated 28 days ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /fetch/metadata/redirect/multiple-redirect-https-downgrade-upgrade.tentative.sub.html | Https downgrade-upgrade prefetch => No headers - Test timed out

Categories

(Core :: DOM: Networking, defect, P5)

defect

Tracking

()

REOPENED

People

(Reporter: intermittent-bug-filer, Assigned: apavel)

References

Details

(Keywords: intermittent-failure, leave-open, Whiteboard: [necko-triaged])

Attachments

(3 files)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=271845058&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/OISNODhvTcqESsRzH5lEDw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-18T09:04:42.016Z] 09:04:42 INFO - TEST-START | /fetch/metadata/redirect/multiple-redirect-https-downgrade-upgrade.tentative.sub.html
[task 2019-10-18T09:04:52.437Z] 09:04:52 INFO - promise callbackpromise_test@http://web-platform.test:8000/resources/testharness.js:589:51
[task 2019-10-18T09:04:52.437Z] 09:04:52 INFO - RunCommonRedirectTests@http://web-platform.test:8000/fetch/metadata/resources/redirectTestHelper.sub.js:106:15
[task 2019-10-18T09:04:52.437Z] 09:04:52 INFO - @http://web-platform.test:8000/fetch/metadata/redirect/multiple-redirect-https-downgrade-upgrade.tentative.sub.html:26:25
[task 2019-10-18T09:04:52.438Z] 09:04:52 INFO - TEST-UNEXPECTED-TIMEOUT | /fetch/metadata/redirect/multiple-redirect-https-downgrade-upgrade.tentative.sub.html | Https downgrade-upgrade prefetch => No headers - Test timed out
[task 2019-10-18T09:04:52.438Z] 09:04:52 INFO - TEST-INFO | expected FAIL
[task 2019-10-18T09:04:52.438Z] 09:04:52 INFO - ......
[task 2019-10-18T09:04:52.438Z] 09:04:52 INFO - TEST-TIMEOUT | /fetch/metadata/redirect/multiple-redirect-https-downgrade-upgrade.tentative.sub.html | took 10410ms
[task 2019-10-18T09:04:52.452Z] 09:04:52 INFO - PID 18635 | 1571389492441 Marionette INFO Stopped listening on port 41995
[task 2019-10-18T09:04:53.143Z] 09:04:53 INFO - Browser exited with return code 0
[task 2019-10-18T09:04:53.143Z] 09:04:53 INFO - PROCESS LEAKS None
[task 2019-10-18T09:04:53.143Z] 09:04:53 INFO - Closing logging queue
[task 2019-10-18T09:04:53.144Z] 09:04:53 INFO - queue closed
[task 2019-10-18T09:04:53.169Z] 09:04:53 INFO - Setting up ssl
[task 2019-10-18T09:04:53.205Z] 09:04:53 INFO - certutil |
[task 2019-10-18T09:04:53.233Z] 09:04:53 INFO - certutil |
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO - certutil |
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO - Certificate Nickname Trust Attributes
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO - SSL,S/MIME,JAR/XPI
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO -
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO - web-platform-tests CT,,
[task 2019-10-18T09:04:53.261Z] 09:04:53 INFO -
[task 2019-10-18T09:04:53.277Z] 09:04:53 INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmpykyh5b.mozrunner
[task 2019-10-18T09:04:53.293Z] 09:04:53 INFO - Starting runner
[task 2019-10-18T09:04:53.875Z] 09:04:53 INFO - PID 18959 | 1571389493870 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: mozillaAddons
[task 2019-10-18T09:04:53.875Z] 09:04:53 INFO - PID 18959 | 1571389493871 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: telemetry
[task 2019-10-18T09:04:53.875Z] 09:04:53 INFO - PID 18959 | 1571389493871 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: resource://pdf.js/
[task 2019-10-18T09:04:53.876Z] 09:04:53 INFO - PID 18959 | 1571389493871 addons.webextension.screenshots@mozilla.org WARN Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: about:reader

[task 2019-10-18T09:04:57.110Z] 09:04:57 INFO - PID 18959 | 1571389497105 Marionette INFO Listening on port 41995

James, could you please take a look at this?
I believe it's caused by the expectations being modified in Bug 1588508.

Flags: needinfo?(james)
See Also: → 1588508, 1586206
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/089f4d285e9a
update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectations r=aryx
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → apavel
Attachment #9102880 - Attachment description: Bug 1589629 - Update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectancies for mac and win coverage. r=jgraham,aryx → Bug 1589629 - Update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectancies. r=jgraham
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db43f2d8a943
Update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectancies. r=jgraham
Flags: needinfo?(james)
Target Milestone: mozilla71 → ---
Target Milestone: --- → mozilla72

This started appearing again after the wpt-sync push was merged to central:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=273119224&repo=mozilla-central&lineNumber=25810

https://hg.mozilla.org/mozilla-central/rev/21357b8e871b#l523.2

James, could you take a look please?

Flags: needinfo?(james)

This will probably come back again after another wpt-sync so leaving this open forever and ever.

Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Target Milestone: mozilla72 → ---
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/146abee7a64e
update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectations. r=aryx

It seems like a bug that it comes cack after every sync, but I need to find some time to investigate further.

Flags: needinfo?(james)
Whiteboard: [necko-triaged]
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d239925c389e
update multiple-redirect-https-downgrade-upgrade.tentative.sub.html expectations. a=test-only
You need to log in before you can comment on or make changes to this bug.