Closed Bug 1589699 Opened 3 months ago Closed 3 months ago

Perma mozilla/tests/service-workers/update_completes_in_disconnected_global.https.html | ServiceWorkerRegistration.update() concluding in a disconnected global - assert_true: when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: DOM: Service Workers, defect, P5)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: intermittent-bug-filer, Assigned: asuth)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=271873242&repo=try
Full log: https://queue.taskcluster.net/v1/task/ULvfANYmTJqjIN6NHNIXuA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-18T12:47:51.695Z] 12:47:51 INFO - TEST-START | /_mozilla/service-workers/update_completes_in_disconnected_global.https.html
[task 2019-10-18T12:47:51.703Z] 12:47:51 INFO - Closing window 23
[task 2019-10-18T12:47:51.814Z] 12:47:51 INFO - PID 4457 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-10-18T12:47:52.664Z] 12:47:52 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | Suppressions used:
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | count bytes template
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | 26 800 nsComponentManagerImpl
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | 611 17713 libfontconfig.so
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | 1 29 libglib-2.0.so
[task 2019-10-18T12:47:52.665Z] 12:47:52 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:53.291Z] 12:47:53 INFO -
[task 2019-10-18T12:47:53.292Z] 12:47:53 INFO - TEST-UNEXPECTED-FAIL | /_mozilla/service-workers/update_completes_in_disconnected_global.https.html | ServiceWorkerRegistration.update() concluding in a disconnected global - assert_true: frame update() should have rejected expected true got false
[task 2019-10-18T12:47:53.293Z] 12:47:53 INFO - @https://web-platform.test:8443/_mozilla/service-workers/update_completes_in_disconnected_global.https.html:60:14
[task 2019-10-18T12:47:53.294Z] 12:47:53 INFO - TEST-OK | /_mozilla/service-workers/update_completes_in_disconnected_global.https.html | took 1597ms
[task 2019-10-18T12:47:53.295Z] 12:47:53 INFO - No more tests
[task 2019-10-18T12:47:53.323Z] 12:47:53 INFO - PID 4457 | 1571402873316 Marionette INFO Stopped listening on port 35962
[task 2019-10-18T12:47:53.566Z] 12:47:53 INFO - PID 4457 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-10-18T12:47:53.614Z] 12:47:53 INFO - PID 4457 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-10-18T12:47:53.616Z] 12:47:53 INFO - PID 4457 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | Suppressions used:
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | count bytes template
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | 26 800 nsComponentManagerImpl
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | 2 288 libfontconfig.so
[task 2019-10-18T12:47:54.653Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.710Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.712Z] 12:47:54 INFO - PID 4457 | Suppressions used:
[task 2019-10-18T12:47:54.714Z] 12:47:54 INFO - PID 4457 | count bytes template
[task 2019-10-18T12:47:54.715Z] 12:47:54 INFO - PID 4457 | 26 800 nsComponentManagerImpl
[task 2019-10-18T12:47:54.716Z] 12:47:54 INFO - PID 4457 | 611 17713 libfontconfig.so
[task 2019-10-18T12:47:54.717Z] 12:47:54 INFO - PID 4457 | 1 29 libglib-2.0.so
[task 2019-10-18T12:47:54.718Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.748Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.750Z] 12:47:54 INFO - PID 4457 | Suppressions used:
[task 2019-10-18T12:47:54.751Z] 12:47:54 INFO - PID 4457 | count bytes template
[task 2019-10-18T12:47:54.752Z] 12:47:54 INFO - PID 4457 | 26 800 nsComponentManagerImpl
[task 2019-10-18T12:47:54.753Z] 12:47:54 INFO - PID 4457 | 611 17713 libfontconfig.so
[task 2019-10-18T12:47:54.753Z] 12:47:54 INFO - PID 4457 | 1 29 libglib-2.0.so
[task 2019-10-18T12:47:54.754Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.967Z] 12:47:54 INFO - PID 4457 | -----------------------------------------------------
[task 2019-10-18T12:47:54.968Z] 12:47:54 INFO - PID 4457 | Suppressions used:
[task 2019-10-18T12:47:54.969Z] 12:47:54 INFO - PID 4457 | count bytes template
[task 2019-10-18T12:47:54.971Z] 12:47:54 INFO - PID 4457 | 26 800 nsComponentManagerImpl
[task 2019-10-18T12:47:54.971Z] 12:47:54 INFO - PID 4457 | 611 17713 libfontconfig.so
[task 2019-10-18T12:47:54.972Z] 12:47:54 INFO - PID 4457 | 1 29 libglib-2.0.so

Do you have the cycles to fix this today (Monday is the last merge from central to beta)?

Component: General → DOM: Service Workers
Flags: needinfo?(bugmail)
Product: Testing → Core
Regressed by: 1587794
Version: Version 3 → unspecified

Failure reason is ServiceWorkerRegistration.update() concluding in a disconnected global - assert_true: frame update() should have rejected expected true got false. Since beta will use the child-intercept implementation and therefore use DOMMozPromiseRequestHolders, the promise that the assertion checks will never resolve/reject, so this test should be enabled only for parent-intercept (which will make it disabled for beta).

I'll add a meta file to disable the test on the sw-e10s flag.

Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Flags: needinfo?(bugmail)

I had authored the test as a mozilla-only WPT which means we can't trivially
run a check for whether parent intercept is enabled from within the test via
consulting with nsIServiceWorkerManager.

Pushed by bugmail@asutherland.org:
https://hg.mozilla.org/integration/autoland/rev/6a540303d1ad
disable parent-intercept specific WPT test when parent-intercept is not enabled. r=perry
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.