If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Offline:`Work Offline' menu item should be checked when offline

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
UI Design
P2
minor
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Blake Ross)

Tracking

Trunk
mozilla1.4alpha

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: checkwin checklinux)

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

15 years ago
To reproduce:
1.  Open Navigator's `File' menu.
2.  Choose `Work Offline'.
3.  Open the `File' menu again.

What you see:
*   `Work Online'.

What you should see:
*   `/ Work Offline'.

If a toggle is presented as `Foo On Bar' and `Foo Off Bar', it is much harder to
see and understand from the wording what the current mode is. Such wording
should only be used, therefore, when (1) the current mode is very obvious, and
(2) the item is very rarely used. Examples of this include `{Show|Hide}
Balloons' in the Help menu of Mac OS 7~9, and `{Show|Hide} the Office Assistant'
in Microsoft Office. Examples do *not* include the offline mode in any browser,
where the current mode is much less obvious.

Bug occurs in:
*   build 2002072103, Mac OS 9.2.2

Does not occur in:
*   Microsoft Internet Explorer 5.1.4
*   iCab 2.7.1
*   Opera 5.0b5
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla1.2alpha
Created attachment 92638 [details] [diff] [review]
patch

Updated

15 years ago
Attachment #92638 - Flags: review+
blake, could you sr this patch here? Thanks
(Assignee)

Comment 3

15 years ago
Comment on attachment 92638 [details] [diff] [review]
patch

This patch is not technically correct, since the toolbar icon also observes the
broadcaster, so you're setting checked on that true.  You really just want to
set checked on the menuitem.  But since you didn't really cause that problem,
I'll sr (but it'd be good if you fixed that).  Move type="checkbox" to the
broadcaster.
Attachment #92638 - Flags: superreview+
Created attachment 92705 [details] [diff] [review]
patch v2

new patch with requested changes.
I use if (menuItem) because there are windows w/ a online/offline item in the
statusbar but without menus (message search, for example)
Created attachment 92704 [details] [diff] [review]
patch v2

new patch with requested changes.
I use if (menuItem) because there are windows w/ a online/offline item in the
statusbar but without menus (message search, for example)
Created attachment 92706 [details] [diff] [review]
patch v2

new patch with requested changes.
I use if (menuItem) because there are windows w/ a online/offline item in the
statusbar but without menus (message search, for example)
Created attachment 92707 [details] [diff] [review]
patch v2

new patch with requested changes.
I use if (menuItem) because there are windows w/ a online/offline item in the
statusbar but without menus (message search, for example)
Created attachment 92708 [details] [diff] [review]
patch v2

new patch with requested changes.
I use if (menuItem) because there are windows w/ a online/offline item in the
statusbar but without menus (message search, for example)
Attachment #92638 - Attachment is obsolete: true
arrrrrg I blame Mozilla for attaching this five times or so, sorry for the spam
Comment on attachment 92708 [details] [diff] [review]
patch v2

transferring r=timeless sr=blake
Attachment #92708 - Flags: superreview+
Attachment #92708 - Flags: review+
Blocks: 159293
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
I want to double check that this is correct behavior:
  -when offline : then wif I go to file|offline|work offline
                  I should see a check mark
  -when online: no check mark

Is this correct?

Using 
2002-09-10-08-trunk nt 4.0
2002091008 trunk Mac OS 10.1.5
2002091108 trnk linux 2.2

I am seeing inconsistency with the checkmark in the menu item 'work offline'.


Some test cases:
  -Initially both browser and Mail 'work offline' menu items are unchecked
   1)
     a) use browser menu item to go offline
     b) go online via mail menu item
     result: browser menu item stil has check mark but mail menu item
             doesn't. The converse of this test case also applies.
   2)
    a) Use mail menu item to go offline
    b) both browser and mail menu item show checkmark
    c) go online via offline icon in mail (lower right hand corner)
    result: both menu items still show check marks

There are more scenarios like this. Other windows that you can go
offline via icon include: seperate mail window, composer, addressbook.

I think this all needs to be fixed.

I am going to reopen this bug.

     
Status: RESOLVED → REOPENED
QA Contact: paw → gchan
Resolution: FIXED → ---

Comment 13

15 years ago
Other test cases
  -going offline via profile mgr (this seemed to work fine)
  -go offline in mail via menu but click "GetMsgs" button
   to go back online

The bug for offline icon not working in other windows
is bug 80970.

Comment 14

15 years ago
FYI, this bug is a dup of Bug 117036, which was marked WONTFIX. Per Mozilla 
guidelines, (http://www.mozilla.org/get-involved.html) bugs that affect 
Mail/News need to go through one of the Mail/News module owners, sspitzer, 
mscott, bienvenu. Mail/News bugs that involve UI, should go through Mail/News UI 
module owner, jglick, as well. Thanks.
jglick, if this doesn't match our spec, let me know.

I'll back it out.
-> default owner as the rest of my ui patches.

jglick, sorry for not contacting you about this change. I was not really aware
that this would touch mailnews as well (the menu there looks pretty different).

anyway, I have stopped working on mozilla ui. let the default owner make a
decision about this.
Assignee: cbiesinger → blaker
Status: REOPENED → NEW
QA Contact: gchan → paw

Comment 17

15 years ago
*** Bug 176499 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
Please take a look at bug 179728.

I bet it's caused by this piece of the patch:
--------------------------------------------------------
+      if (menuItem)
+        broadcaster.removeAttribute("checked");
--------------------------------------------------------

Should be (I think):
--------------------------------------------------------
+      if (menuItem)
+        menuItem.removeAttribute("checked");
--------------------------------------------------------
Blocks: 179728

Comment 19

15 years ago
Jennifer, Blake and Seth,

I've seen some bugs and or discussion about this:
see bug 179728, bug 117036. Maybe more bugs out there.

I am assuming we want to go back to the old way?
If so, Whenever Seth or Blake get some free time,
do we want them to back the change out and go back to old way?

I realize this probably low on their priority list. If I
see more bugs on this not working properly, I will dupe
against this bug. No hurry.

Comment 20

15 years ago
*** Bug 180853 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
nominating for nsbeta1 to switch back to the old way..
assuming seth/jennifer don't have objections
Keywords: nsbeta1

Comment 22

15 years ago
jglick et al, you need to get approval from blake or ben or some browser owner
before you make changes that affect the browser side. so don't just go rampaging
the other way.
No longer blocks: 159293

Comment 23

15 years ago
That's Cool. Both Browser and Mail modules owners should decide
what's the best way to handle this. I'm nominating on the Mail point
of view.

But using commercial trunk
rv:1.3a Gecko/20021204 on XP

In browser: if I do file|workoffline, i see checkmark.
But if I go online via the offline widget in lower right handcorner,
the workoffline menu item is still checked.


Comment 24

15 years ago
gchan: see comment 18.

Comment 25

15 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 26

15 years ago
Created attachment 114007 [details] [diff] [review]
Turned Wesha's comment 18 into a patch

Obsoleting existing patches as they are obsolete or checked in.

See bug 179728 for an alternative approach.
Attachment #92708 - Attachment is obsolete: true
Attachment #92704 - Attachment is obsolete: true
Attachment #92705 - Attachment is obsolete: true
Attachment #92706 - Attachment is obsolete: true
Attachment #92707 - Attachment is obsolete: true
> See bug #179728 for an alternative approach.

neil, will your fix in bug #179728 address this bug completely?  If so, let's
mark it a dup and drive in your fix for that bug.

Updated

15 years ago
Target Milestone: mozilla1.2alpha → mozilla1.4alpha
from neil:

"Technically this bug should have been resolved fixed, as a near-perfect fix was
checked in, and bug 179728 is merely a regression"

I'll let him close the bug out.

Comment 29

15 years ago
Well, either this or bug 179728 needs to be resolved - I picked this one :-)
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 30

14 years ago
VERIFIED: Mac OS X, Mozill 1.6b.

Also, I resolved bug 176499, which had become a Mac-only problem where the menu
item was simply not flipping back and forth.
Status: RESOLVED → VERIFIED
QA Contact: pawyskoczka → benc
Summary: `Work Offline' menu item isn't checked like in most other browsers → Offline:`Work Offline' menu item should be checked when offline
Whiteboard: checkwin checklinux
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.