Closed Bug 1589900 Opened 2 months ago Closed Last month

Search box in private browsing won't load any search engine if no other instances of Firefox are already running

Categories

(Firefox :: Private Browsing, defect, P1)

62 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- verified
firefox70 --- wontfix
firefox71 --- verified
firefox72 + verified

People

(Reporter: jollypaluani, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image 3.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

The following problem will occur about 7-8 times out of 10:
-Close all instances of Firefox
-Click on a Private browsing "external" icon of Firefox (eg: the icon located in the Firefox jumplist in the Windows Seven task bar) in order to DIRECTLY open a single "private browsing" window. Infact, the following problem will NOT occur if I click on the private browsing icon located "inside" Firefox, I mean the one in the sandwich menu at the top-right of an already-opened window of Firefox.
-ISSUE: The search box in the middle of the purple "Private browsing" starting page will not be clickable and no (default) search engine loaded in it (no Google icon in it: it will be blank). My Firefox default search engine is Google.
-This problem is related only to that search box: no problem searching (Googling) the web using Firefox's Address bar or any other search method available in Firefox itself.
-If I refresh the page (the purple starting page of Private browsing), its search box will immediately start working properly, displaying the Google logo and becoming clickable (in order to place the mouse cursor inside and start writing the needed search term).
-Please note that if even a single instance of Firefox is ALREADY running, the problem described above will never occur.

Actual results:

The Search box in the middle of the purple page of "Private browsing" will not load the (default) search engine if Firefox is opened when NO other instances of the browser are running: that search box will be inusable.

Expected results:

The Search box in the middle of the purple page of "Private browsing" should work all the times, not only when Firefox is "ALREADY" running and a new Private browsing window or tab is opened.

Component: Untriaged → Private Browsing

I've was able to reproduce this on a Windows 10 virtual machine. Took about 5/6 attempts before I hit it.

The web console message is:

ReferenceError: RPMIsWindowPrivate is not defined aboutPrivateBrowsing.js:8:7

There's no errors in the browser console.

This was added in bug 1459204. I'm guessing that something hasn't started up fully before about:privatebrowsing gets there.

Christoph, any ideas?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ckerschb)
Regressed by: 1459204

[Tracking Requested - why for this release]: since it affects one of search access points...

A bug that causes us not to display a search box sounds very serious, marking this as P1 and assigning to Christoph for now. Christoph, if you don't have the cycles to take this please let me know ASAP. Thanks!

Assignee: nobody → ckerschb
Priority: -- → P1
Duplicate of this bug: 1590867

(In reply to :ehsan akhgari from comment #3)

A bug that causes us not to display a search box sounds very serious, marking this as P1 and assigning to Christoph for now. Christoph, if you don't have the cycles to take this please let me know ASAP. Thanks!

Sorry for the lag here - Gijs offered to take a look. Gijs, feel free to assign to yourself in case you have an idea how to fix it - thanks so much!

Flags: needinfo?(ckerschb) → needinfo?(gijskruitbosch+bugs)
Duplicate of this bug: 1592217
Assignee: ckerschb → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Duplicate of this bug: 1574970

(In reply to Dave Townsend [:mossop] (he/him) from bug 1574970 comment #6)

But I don't think we need to figure that out here. I'd just ensure the privatebrowsing case is initialised here: https://searchfox.org/mozilla-central/source/browser/components/BrowserContentHandler.jsm#527

This seems like it's enough to fix it for me.

Version: 69 Branch → 62 Branch
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/988f70454ebd
ensure we initialize about:privatebrowsing remote page handler before loading it from the commandline, r=mossop
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9106138 [details]
Bug 1589900 - ensure we initialize about:privatebrowsing remote page handler before loading it from the commandline, r?johannh,Mossop,ehsan

Beta/Release Uplift Approval Request

  • User impact if declined: Broken private browsing page
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Straightforward patch that allows earlier initialization of the same code only in the affected cases.
  • String changes made/needed: nope
Attachment #9106138 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9106138 [details]
Bug 1589900 - ensure we initialize about:privatebrowsing remote page handler before loading it from the commandline, r?johannh,Mossop,ehsan

Fix for a P1 regression in our search box in private browsing, uplift approved for 71 beta 8 and let's get it verified by QA on beta, thanks.

Attachment #9106138 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

The issue is still reproducible when using a new profile on Windows 7 / Windows 10 using Firefox Nightly 72.0a1 (20191106095742)

In Firefox 71b7, it works perfect with the command parameters --private-window
I did not test via the jumplist, it was empty of choices.

(In reply to Peter_M from comment #15)

The issue is still reproducible when using a new profile on Windows 7 / Windows 10 using Firefox Nightly 72.0a1 (20191106095742)

Can you provide some more detail on what you're doing, exactly?

(In reply to Julien L. from comment #16)

In Firefox 71b7, it works perfect with the command parameters --private-window

This patch isn't in 71b7, so that's interesting... It'll be in b8.

Oops, submitted my previous comment without finishing my question...

(In reply to :Gijs (he/him) from comment #17)

(In reply to Peter_M from comment #15)

The issue is still reproducible when using a new profile on Windows 7 / Windows 10 using Firefox Nightly 72.0a1 (20191106095742)

Can you provide some more detail on what you're doing, exactly, and what results you're seeing? FWIW, I consistently see the google icon not showing up in either about:privatebrowsing or about:newtab until I hover over the page and/or search box, but otherwise everything now works. I think the icon is on file separately and unrelated to this problem.

Flags: needinfo?(peter.magyari)

(In reply to :Gijs (he/him) from comment #17)

(In reply to Julien L. from comment #16)

In Firefox 71b7, it works perfect with the command parameters --private-window

This patch isn't in 71b7, so that's interesting... It'll be in b8.

I'll test the beta8, and see if there is a difference. When will it be released please?

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Julien L. from comment #19)

(In reply to :Gijs (he/him) from comment #17)

(In reply to Julien L. from comment #16)

In Firefox 71b7, it works perfect with the command parameters --private-window

This patch isn't in 71b7, so that's interesting... It'll be in b8.

I'll test the beta8, and see if there is a difference. When will it be released please?

Friday (US pacific time) - for future reference, all this and more in https://calendar.google.com/calendar/embed?src=bW96aWxsYS5jb21fZGJxODRhbnI5aTh0Y25taGFiYXRzdHY1Y29AZ3JvdXAuY2FsZW5kYXIuZ29vZ2xlLmNvbQ , linked from https://wiki.mozilla.org/Release_Management/Calendar . :-)

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to :Gijs (he/him) from comment #18)

Oops, submitted my previous comment without finishing my question...

(In reply to :Gijs (he/him) from comment #17)

(In reply to Peter_M from comment #15)

The issue is still reproducible when using a new profile on Windows 7 / Windows 10 using Firefox Nightly 72.0a1 (20191106095742)

Can you provide some more detail on what you're doing, exactly, and what results you're seeing? FWIW, I consistently see the google icon not showing up in either about:privatebrowsing or about:newtab until I hover over the page and/or search box, but otherwise everything now works. I think the icon is on file separately and unrelated to this problem.

Hi,

Using the latest Nightly (20191106215426) I've added "-private" command to the shortcut from my desktop.
I create a new profile from the profile manager and start it up.
The search bar from about:privatebrowsing is unclickable and the google icon is missing.
This only happens when I'm using the profile for the first time, if I close and re-open FX with the same profile it works just fine.

Flags: needinfo?(peter.magyari)
See Also: → 1594719

(In reply to Peter_M from comment #21)

Using the latest Nightly (20191106215426) I've added "-private" command to the shortcut from my desktop.

This bug was about using -private-window, and happened for all uses of a profile rather than just the first one. I filed bug 1594719 for the issue you're seeing.

I did not know there was a difference between those two commands.
At least we've uncovered a new issue there.

I've reproduced the issue on Win 10 /Win 7/ MacOS 10.13 using Firefox Nightly 71.0a1(20191018095340) and Firefox Beta 71.0b7(20191104135555)
I've also verified this issue using Firefox Nightly 72.0a1(20191107094905) and Firefox Beta 71.0b8(20191107101713) and it has been fixed.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Does this need an ESR68 approval request? It'd need a rebased patch if the answer is yes.

Flags: needinfo?(gijskruitbosch+bugs)
Attached patch Patch for esr68Splinter Review
Flags: needinfo?(gijskruitbosch+bugs)

Comment on attachment 9110064 [details] [diff] [review]
Patch for esr68

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: unbreaking core functionality (taskbar menu on windows)
  • User impact if declined: see above
  • Fix Landed on Version: 72, uplifted to 71
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): We're ensuring some initialization happens early enough so that it takes effect before we rely on it having happened. It's a straightforward patch that should be safe.
  • String or UUID changes made by this patch: no
Attachment #9110064 - Flags: approval-mozilla-esr68?
Comment on attachment 9110064 [details] [diff] [review]
Patch for esr68

Fixes broken search in PB mode in some cases. Approved for 68.3esr.
Attachment #9110064 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified fixed using Firefox 68.3.0esr (20191126000427) on Windows 7 / Windows 10 and MacOS 10.15.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.