Closed Bug 1589949 Opened 3 years ago Closed 3 years ago

Autoscroll doesn't work with wayland anymore

Categories

(Core :: Widget: Gtk, defect, P2)

71 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox70 --- unaffected
firefox71 --- affected
firefox72 --- fixed

People

(Reporter: dano.kutka, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

  1. Start latest nightly with MOZ_ENABLE_WAYLAND=1 and enabled Autoscroll in settings
  2. Press middle button

Actual results:

Autoscrolling didn't started, nothing happend

Expected results:

Autoscrolling should work.
It is working with X11. Tested DE: sway, Gnome, Gnome X11
Distribution: Manjaro stable

Did that ever worked? Can you try to find a regression window by https://mozilla.github.io/mozregression/? Thanks.

Blocks: wayland
Flags: needinfo?(dano.kutka)
Priority: -- → P3
Priority: P3 → P2
 2:33.99 INFO: Last good revision: cdcbac30666276f484747875e430ab0a74f123fb (2019-10-16)
 2:33.99 INFO: First bad revision: c260b3893967535faf023573fdd429fc48738778 (2019-10-17)
[...]
 3:22.52 INFO: Narrowed inbound regression window from [273c3db8, c260b389] (3 builds) to [a3a8917a, c260b389] (2 builds) (~1 steps left)
 3:22.52 INFO: No more inbound revisions, bisection finished.
 3:22.52 INFO: Last good revision: a3a8917a857faf969d078f945fddbdfaa0a0537a
 3:22.52 INFO: First bad revision: c260b3893967535faf023573fdd429fc48738778
 3:22.52 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a3a8917a857faf969d078f945fddbdfaa0a0537a&tochange=c260b3893967535faf023573fdd429fc48738778

 3:24.47 ERROR: The url 'https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=c260b3893967535faf023573fdd429fc48738778&full=1' returned a 404 error. Please check the validity of the url.

It worked before. Comment 2 seems correct.

Flags: needinfo?(dano.kutka)

with build 2019-09-28 i experiencing occasionally normal scroll with touchscreen/touchpad stop working. Just mentioning, but I guess it isn't related.

Did one more mozregression, since something derped out the first time:

 3:19.33 INFO: Narrowed inbound regression window from [e71fb039, e22edfaa] (3 builds) to [e71fb039, 48951378] (2 builds) (~1 steps left)
 3:19.33 INFO: No more inbound revisions, bisection finished.
 3:19.33 INFO: Last good revision: e71fb039af065fbf81101c4c94ed48484242d2b1
 3:19.33 INFO: First bad revision: 48951378e166b2a1e84c923681b29e0c3e59a9fb
 3:19.33 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e71fb039af065fbf81101c4c94ed48484242d2b1&tochange=48951378e166b2a1e84c923681b29e0c3e59a9fb

Regressed by bug 1565401.

Regressed by: 1565401

I think this is a variant of Bug 1589601, let's see if it's fixed when it lands.

I can confirm it's working in the 2019-11-06-09-57-42 Nightly.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.