Closed Bug 1590071 Opened 10 months ago Closed 10 months ago

Missing "review" section on https://www.yelp.ie/dublin when Fingerprinters are enabled

Categories

(Core :: Privacy: Anti-Tracking, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- affected

People

(Reporter: hani.yacoub, Unassigned)

References

(Blocks 1 open bug)

Details

Affected versions

  • Firefox Nightly 71.0a1 (2019-10-20)

Affected platforms

  • macOS 10.14
  • Windows 10 x64
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Launch Firefox.
  2. Go to about:preferences#privacy and from Custom section un-check all items expect for "Fingerprinters".
  3. Go to https://www.yelp.ie/dublin
  4. Observe "Help the Community" section.

Expected result

  • "Help the Community" section should be displayed.

Actual result

I'm not able to reproduce this. I don't see any fingerprinters blocked on this page, and I am able to see the "Help the Community" box with fingerprinting blocking enabled. Hani, would you mind to confirm that you see a fingerprinting domain in the content blocking doorhanger and share the fingerprinting domain?

I suspect Yelp is A/B testing this box. I initially didn't see it on any pageload (even with content blocking off). I then cleared my browsing history and started seeing it on every pageload (with fingerprinting blocking enabled).

Flags: needinfo?(hani.yacoub)
Type: task → defect

Closing this bug as resolved invalid.
I don't see any Fingerprinters blocked on this page either now, but somehow only when Fingerprinters were enabled I managed to reproduce the issue mentioned above.

Flags: needinfo?(hani.yacoub)
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.