Closed Bug 1590128 Opened 2 years ago Closed 2 years ago

Moving the default homepage "start.firefoxchina.cn" to China edition/users only

Categories

(Firefox :: General, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: yfdyh000, Unassigned)

References

Details

This is not good to set up the homepage in the language pack rather than code / preinstallation. Some ordinary users will complain that they got the region-specific homepage even downloaded from the ftp.mozilla.org, and the recent (and a few times in the past) increase in online marketing campaigns.[1][2]

In addition, the zh-CN locale is actually Simplified Chinese language pack, it is also for other users in Singapore, Malaysia, and other outside China.

p.s. browser.startup.homepage = http://start.firefoxchina.cn is still http, it is the lack of maintenance and protection, the site has support https.

1: https://www.firefox.net.cn/read-121258-1
2: https://www.solidot.org/story?sid=62306

Flags: needinfo?(l10n)

This is not a localization choice, it's a product decision.

@Hector
Any idea who would be me the right person to redirect this too?

Flags: needinfo?(l10n) → needinfo?(bzhao)
See Also: → 1467698
Duplicate of this bug: 1589991

In my opinion, start.firefoxchina.cn should be removed completely. See also my comment #4 on https://bugzilla.mozilla.org/show_bug.cgi?id=1589991 .

Duplicate of this bug: 1467698

:selenamarie is looking into this.

This site was an authentic site from Mozilla China. Per Jack Guo, "We own Firefox.com.cn. It is authentic. We do ad on "11/11" (Taobao's shopping festival), for a very short period of time, and once a year. "

There was never a doubt about who owns the start page.

The question for this specific bug is if the firefox.com.cn start page should be set as default for all users of Simplified Chinese (zh-CN), or only for those who download the repackaged version from the Mozilla China website. Currently it's the former, because of the way the system is set up.

Who would own the product decision for that?

I am currently digging into that as well.
It is likely the China office.

(In reply to Marissa (Reese) Wood from comment #9)

I am currently digging into that as well.
It is likely the China office.

Any update on this Reese?

Flags: needinfo?(marissawood)

Yes, thanks so much for the ping. It should be set as default for all users of Simplified Chinese.
Note for me - email from Jack Gua on 11/26/2019.

Flags: needinfo?(marissawood)

Sam and Flod, based on the guidance from Reese in the previous comment, is there any action required here to have the the page in question be set as the default for all users of Simplified Chinese?

Flags: needinfo?(sfoster)
Flags: needinfo?(francesco.lodolo)

Not that I'm asked, but I'll chime in with my 2 cts.

As for this particular bug, this makes us end on a WONTFIX.

The way this is currently implemented is tied to single-locale repacks and non-Fluent l10n, so we'll need to find an alternative way to implement the status quo, but I guess that's a different bug.

Overlapped with Axel. The homepage is already set for all zh-CN users, so there are no changes required.

It would be nice to move that settings into code, and not in localization files, but that's a different bug.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(sfoster)
Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(bzhao)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.