Closed Bug 1590229 Opened 11 months ago Closed 10 months ago

[wpt-sync] Sync PR 19814 - taskcluster: Use the mach logger instead of tbpl for stdout logging

Categories

(Testing :: web-platform-tests, task, P4)

task

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Attachments

(1 file)

Sync web-platform-tests PR 19814 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/19814
Details from upstream follow.

Carlos Alberto Lopez Perez <clopez@igalia.com> wrote:

taskcluster: Use the mach logger instead of tbpl for stdout logging

It seems that some runs of webkitgtk_minibrowser are still timing out on taskcluster

It will be very useful to me to be able to see the timestamp of the lines printed on taskcluster so that I can see if the issue is caused because the last test ran has hanged or if is another issue.

This PR switches the log handler uses for printing results in stdout for taskcluster from tbpl to match.

The reasons for this:

  • With the mach logger a timestamp of when a test starts or ends is printed, which is very useful to detect tests hanging·

  • On top of that the mach logger provides a more useful summary at the end of the suite run because it gives information about how many tests (and not only subtests) failed, also it summarizes the cause of the unexpected results (like error or timeout).

  • Also, the logs produces by the mach logger are more compact, around half the size in megabytes is needed for storing a log with match (instead of tbpl)

  • The environment variable TERM=dumb is passed to disable colors to be printed on the terminal

Result changes from PR not available.
Result changes from PR not available.

Automatic update from web-platform-tests
taskcluster: Use the mach logger instead of tbpl for stdout logging. (#19814)

  • With the mach logger a timestamp of when a test starts or ends
    is printed, which is very useful to detect tests taking too much
    time to complete or hanging.

  • On top of that the mach logger provides a more useful summary at
    the end of the suite run because it gives information about how
    many tests (and not only subtests) failed, also it summarizes the
    cause of the unexpected results (like error or timeout).

  • Also, the logs produces by the mach logger are more compact, around
    half the size in megabytes is needed for storing a log with match
    (instead of tbpl)

  • The environment variable TERM=dumb is passed to disable colors to
    be printed on the terminal

--

wpt-commits: 8e9016586f4563dfcb4090882177e3c10866abe7
wpt-pr: 19814

Result changes from PR not available.
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6d13f32c1b0
[wpt PR 19814] - taskcluster: Use the mach logger instead of tbpl for stdout logging, a=testonly
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.