Closed Bug 1590237 Opened 3 years ago Closed 3 years ago

Deal with performance issues from Address Book rewrite

Categories

(MailNews Core :: Address Book, defect)

Unspecified
All
defect
Not set
normal

Tracking

(thunderbird_esr68 unaffected, thunderbird70 wontfix)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr68 --- unaffected
thunderbird70 --- wontfix

People

(Reporter: standard8, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: perf, regression)

Bug 1572324 and maybe others have started rewriting the address book with a database and sql. Joshua has commented about the potential performance issues of the database in bug 1572324 comment 24.

These should be addressed before the address book gets shipped. Hence, filing this as a separate bug so that it gets noticed and can be tracked.

Keywords: perf
Keywords: regression
OS: Unspecified → All
Regressed by: 1572324
Version: unspecified → 70

too late for 73 beta - but can we address this during 74?

Assignee: nobody → geoff
Flags: needinfo?(geoff)

I won't be making any more changes to the database schema until after some big changes to the address book interfaces. Although Joshua does make some good points I'm not aware of any significant performance regressions remaining.

Flags: needinfo?(geoff)

So WFM?

Duplicate of this bug: 1602004
Duplicate of this bug: 1611312

(In reply to Magnus Melin [:mkmelin] from comment #3)

So WFM?

Not for the person's bug I just duped to this. (I duped two, but they are from the same person)

See Also: → 1597394
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.