Closed Bug 1590439 Opened 2 years ago Closed 2 years ago

startupcache/test/browser/browser_startupcache_telemetry.js | Uncaught exception - at chrome://mochitests/content/browser/startupcache/test/browser/browser_startupcache_telemetry.js:23 when Gecko version increases to 73 on 2019-12-02

Categories

(Core :: XPCOM, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1590385
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- affected

People

(Reporter: nataliaCs, Unassigned)

References

(Regression)

Details

[Tracking Requested - why for this release]:
Version Increase: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=de9c063a11c4dff69eadce48a38205c01441aa3a&searchStr=browser-chrome&selectedJob=272386749

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272386749&repo=try&lineNumber=6274

[task 2019-10-22T13:45:47.842Z] 13:45:47 INFO - TEST-START | startupcache/test/browser/browser_startupcache_telemetry.js
[task 2019-10-22T13:45:48.572Z] 13:45:48 INFO - TEST-INFO | started process screentopng
[task 2019-10-22T13:45:49.318Z] 13:45:49 INFO - TEST-INFO | screentopng: exit 0
[task 2019-10-22T13:45:49.318Z] 13:45:49 INFO - Buffered messages logged at 13:45:47
[task 2019-10-22T13:45:49.318Z] 13:45:49 INFO - Entering test bound
[task 2019-10-22T13:45:49.319Z] 13:45:49 INFO - Buffered messages finished
[task 2019-10-22T13:45:49.319Z] 13:45:49 INFO - TEST-UNEXPECTED-FAIL | startupcache/test/browser/browser_startupcache_telemetry.js | Uncaught exception - at chrome://mochitests/content/browser/startupcache/test/browser/browser_startupcache_telemetry.js:23 - TypeError: snapshot.parent.STARTUP_CACHE_REQUESTS is undefined
[task 2019-10-22T13:45:49.319Z] 13:45:49 INFO - Stack trace:
[task 2019-10-22T13:45:49.320Z] 13:45:49 INFO - histValue@chrome://mochitests/content/browser/startupcache/test/browser/browser_startupcache_telemetry.js:23:5
[task 2019-10-22T13:45:49.320Z] 13:45:49 INFO - @chrome://mochitests/content/browser/startupcache/test/browser/browser_startupcache_telemetry.js:25:16
[task 2019-10-22T13:45:49.320Z] 13:45:49 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1067:34
[task 2019-10-22T13:45:49.320Z] 13:45:49 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1102:11
[task 2019-10-22T13:45:49.321Z] 13:45:49 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:930:14
[task 2019-10-22T13:45:49.321Z] 13:45:49 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:805:67
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - Leaving test bound
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - GECKO(7262) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - GECKO(7262) | MEMORY STAT | vsize 2821MB | residentFast 344MB | heapAllocated 155MB
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - TEST-OK | startupcache/test/browser/browser_startupcache_telemetry.js | took 741ms
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - checking window state
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - TEST-UNEXPECTED-FAIL | startupcache/test/browser/browser_startupcache_telemetry.js | Found an unexpected browser window at the end of test run -
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - GECKO(7262) | must wait for focus
[task 2019-10-22T13:45:49.323Z] 13:45:49 INFO - GECKO(7262) | JavaScript error: resource://specialpowers/SpecialPowersParent.jsm, line 605: TypeError: this.manager.rootFrameLoader is null
[task 2019-10-22T13:45:49.324Z] 13:45:49 INFO - GECKO(7262) | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
[task 2019-10-22T13:45:49.324Z] 13:45:49 INFO - Console message: [JavaScript Error: "TypeError: this.manager.rootFrameLoader is null" {file: "resource://specialpowers/SpecialPowersParent.jsm" line: 605}]
[task 2019-10-22T13:45:49.324Z] 13:45:49 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED: "]

Flags: needinfo?(dothayer)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1590385
Flags: needinfo?(dothayer)
You need to log in before you can comment on or make changes to this bug.