Closed Bug 1590608 Opened 1 year ago Closed 1 year ago

Intermittent toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | We have first-party set on storagePrincipal - "" == "example.net" -

Categories

(Core :: Privacy: Anti-Tracking, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1588241

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Filed by: dvarga [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=272469442&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/ewzqWbWGTS2XTcRv2lwapg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-22T21:55:52.058Z] 21:55:52     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 0}]
[task 2019-10-22T21:55:52.058Z] 21:55:52     INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | We don't have first-party set on nodePrincipal - "" == "" - 
[task 2019-10-22T21:55:52.058Z] 21:55:52     INFO - Buffered messages finished
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | We have first-party set on storagePrincipal - "" == "example.net" - 
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - Stack trace:
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - resource://testing-common/content-task.js line 110 > eval:ifr.onload:13
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - GECKO(9032) | [Child 6576, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file z:/build/build/src/dom/base/ThirdPartyUtil.cpp, line 217
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - Sending code to the 3rd party content
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - GECKO(9032) | ++DOCSHELL 0000015C96F1D800 == 7 [pid = 5816] [id = {81c6c7ee-99da-4e33-958a-cbb583d43c7a}]
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - GECKO(9032) | ++DOMWINDOW == 19 (0000015C979162E0) [pid = 5816] [serial = 998] [outer = 0000000000000000]
[task 2019-10-22T21:55:52.059Z] 21:55:52     INFO - GECKO(9032) | ++DOMWINDOW == 20 (0000015C99E56400) [pid = 5816] [serial = 999] [outer = 0000015C979162E0]
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - GECKO(9032) | [Child 5816, Main Thread] WARNING: NS_ENSURE_TRUE(frame) failed: file z:/build/build/src/layout/base/nsPresContext.cpp, line 821
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - GECKO(9032) | JavaScript error: resource:///modules/sessionstore/SessionStore.jsm, line 912: TypeError: aBrowser is null
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - GECKO(9032) | [Parent 9192, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, mozilla::ipc::IPCResult::Ok()) failed with result 0x80570021: file z:/build/build/src/dom/ipc/BrowserParent.cpp, line 2782
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - Console message: [JavaScript Error: "TypeError: aBrowser is null" {file: "resource:///modules/sessionstore/SessionStore.jsm" line: 912}]
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - GECKO(9032) | ++DOMWINDOW == 21 (0000015C99E51800) [pid = 5816] [serial = 1000] [outer = 0000015C979162E0]
[task 2019-10-22T21:55:52.060Z] 21:55:52     INFO - GECKO(9032) | [Child 5816, Main Thread] WARNING: NS_ENSURE_TRUE(frame) failed: file z:/build/build/src/layout/base/nsPresContext.cpp, line 821
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 27 column: 19 source: "http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html"}]
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - GECKO(9032) | --DOCSHELL 0000015C90C57000 == 6 [pid = 5816] [id = {42be191c-e5cd-4cea-b67e-33d20f187671}] [url = http://not-tracking.example.com/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html]
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 20 (0000015C96F51C00) [pid = 5816] [serial = 984] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - GECKO(9032) | --DOCSHELL 0000015C96F18800 == 5 [pid = 5816] [id = {420c3225-70a3-423e-a7f5-ef5b99c33e84}] [url = http://not-tracking.example.com/browser/toolkit/components/antitracking/test/browser/3rdPartyStorageWO.html]
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - GECKO(9032) | --DOCSHELL 0000015C90C54800 == 4 [pid = 5816] [id = {0a277f7c-4867-4be8-a76b-7cc0f226e9f3}] [url = http://example.net/browser/toolkit/components/antitracking/test/browser/page.html]
[task 2019-10-22T21:55:52.101Z] 21:55:52     INFO - GECKO(9032) | --DOCSHELL 0000015C96F92000 == 3 [pid = 5816] [id = {bd6f5c4c-e126-4b27-87de-84383053d9c8}] [url = http://not-tracking.example.com/browser/toolkit/components/antitracking/test/browser/3rdPartyOpenUI.html?messageme]
[task 2019-10-22T21:55:52.121Z] 21:55:52     INFO - GECKO(9032) | [Child 5816, Main Thread] WARNING: NS_ENSURE_TRUE(frame) failed: file z:/build/build/src/layout/base/nsPresContext.cpp, line 821
[task 2019-10-22T21:55:52.182Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 19 (000001EB716EB800) [pid = 2908] [serial = 795] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.183Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 18 (000001EB72F71C00) [pid = 2908] [serial = 798] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.183Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 17 (000001EB735DF800) [pid = 2908] [serial = 809] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.183Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 16 (000001EB7164C800) [pid = 2908] [serial = 789] [outer = 0000000000000000] [url = http://example.net/browser/toolkit/components/antitracking/test/browser/page.html]
[task 2019-10-22T21:55:52.183Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 15 (000001EB735E2800) [pid = 2908] [serial = 806] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.183Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 14 (000001EB70F7A800) [pid = 2908] [serial = 812] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.184Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 13 (000001EB7352E400) [pid = 2908] [serial = 803] [outer = 0000000000000000] [url = about:blank]
[task 2019-10-22T21:55:52.196Z] 21:55:52     INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | Doesn't yet have storage access - true == true - 
[task 2019-10-22T21:55:52.196Z] 21:55:52     INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | Our 3rd party URL shouldn't be HTTPS - true == true - 
[task 2019-10-22T21:55:52.196Z] 21:55:52     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorageWO.html" line: 0}]
[task 2019-10-22T21:55:52.260Z] 21:55:52     INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | We expected 1 connection - true == true - 
[task 2019-10-22T21:55:52.260Z] 21:55:52     INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 22 column: 14 source: "http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html line 25 > eval"}]
[task 2019-10-22T21:55:52.279Z] 21:55:52     INFO - GECKO(9032) | [Child 5816, Wor[Paker Launcher] WARNrent 9192, GeI
[task 2019-10-22T21:55:52.279Z] 21:55:52     INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/antitracking/test/browser/browser_partitionedSharedWorkers.js | We expected 1 connection for 3rd party SharedWorker - false == true - 
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - Stack trace:
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - resource://testing-common/content-task.js line 110 > eval:msg:31
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - GECKO(9032) | NG: '!laucko_IOThread] WARncherData->mIPCActiNING: pipe error: 109: file z:/build/build/src/ivpec/', chromifium/src/chrome/common/ipc_le z:/build/build/src/dom/channel_wiworkers/remoteworkers/Remn.cc, line 341
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - GECKO(9032) | oteWorkerChild.cpp, line 793
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - GECKO(9032) | ++DOCSHELL 0000015C96F18800 == 4 [pid = 5816] [id = {32f1426f-956d-4719-8f8e-ce0150d858de}]
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - GECKO(9032) | ++DOMWINDOW == 21 (0000015C979164C0) [pid = 5816] [serial = 1001] [outer = 0000000000000000]
[task 2019-10-22T21:55:52.280Z] 21:55:52     INFO - GECKO(9032) | ++DOMWINDOW == 22 (0000015C96F54800) [pid = 5816] [serial = 1002] [outer = 0000015C979164C0]
[task 2019-10-22T21:55:52.281Z] 21:55:52     INFO - GECKO(9032) | [Child 5816, Main Thread] WARNING: NS_ENSURE_TRUE(frame) failed: file z:/build/build/src/layout/base/nsPresContext.cpp, line 821
[task 2019-10-22T21:55:52.286Z] 21:55:52     INFO - GECKO(9032) | JavaScript error: resource:///modules/sessionstore/SessionStore.jsm, line 912: TypeError: aBrowser is null
[task 2019-10-22T21:55:52.286Z] 21:55:52     INFO - GECKO(9032) | [Parent 9192, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, mozilla::ipc::IPCResult::Ok()) failed with result 0x80570021: file z:/build/build/src/dom/ipc/BrowserParent.cpp, line 2782
[task 2019-10-22T21:55:52.326Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 12 (000001EB72F0AF20) [pid = 2908] [serial = 808] [outer = 0000000000000000] [url = http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyOpenUI.html?messageme]
[task 2019-10-22T21:55:52.326Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 11 (000001EB72F0BA60) [pid = 2908] [serial = 805] [outer = 0000000000000000] [url = http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorageWO.html]
[task 2019-10-22T21:55:52.326Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 10 (000001EB72F0B880) [pid = 2908] [serial = 802] [outer = 0000000000000000] [url = http://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyStorage.html]
[task 2019-10-22T21:55:52.326Z] 21:55:52     INFO - GECKO(9032) | --DOMWINDOW == 9 (000001EB72F0B6A0) [pid = 2908] [serial = 799] [outer = 0000000000000000] [url = http://example.net/browser/toolkit/components/antitracking/test/browser/page.html]
Duplicate of this bug: 1590600
See Also: → 1570912
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a80d685d5862
Disable browser_partitionedSharedWorkers.js on Mac and Win r=gbrown
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jyavenard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1588241
You need to log in before you can comment on or make changes to this bug.