Closed Bug 1590666 Opened 4 months ago Closed 4 months ago

Message Filter Editor Only Showing One Match Condition since dialogue comes up too small

Categories

(Thunderbird :: Filters, defect)

defect
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird71 fixed, thunderbird72 fixed)

RESOLVED FIXED
Thunderbird 72.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird71 --- fixed
thunderbird72 --- fixed

People

(Reporter: franklake, Assigned: Paenglab)

Details

Attachments

(3 files, 1 obsolete file)

Attached image Capture.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I am editing a message filter rule and know there are more than one Match condition. However I am unable to see the others as no scroll bar exists.

Actual results:

Only way I can see the rule is to edit the msgFilterRules.dat file manually.

name="* Deletes *"
enabled="yes"
type="17"
action="Delete"
condition="OR (subject,begins with,[Norton AntiSpam]) OR (subject,begins with,[SUSPICIOUS MESSAGE]) OR (subject,begins with,[SPAM]) OR (from,is,nigel@innercircleservice.com) OR (from,is,info@tipstersempire.co.uk) OR (from,is,info@jpwracingtipster.com) OR (from,is,support@jpwscoop6.com)"

Expected results:

I used to get a scroll bar to see the additional conditions.

Yes, the windows comes up a little to small. You can drag one of the corners to make it bigger.

Richard, should we action this to make the window come up bigger?

Flags: needinfo?(richard.marti)
Summary: Message Filter Editor Only Showing One Match Condition. → Message Filter Editor Only Showing One Match Condition since dialogue comes up too small

This happens because we added new options in the Apply filter when: area without making the dialog taller.
We have two options:

  • Make the dialog taller. It's not too tall and still fits in small screens.
  • Rearrange the options in the Apply filter when: area like putting in two columns. This saves a bit of the space but how should we arrange them to look good and still working well with other languages?

Alessandro, what do you think about option two? If option two, how would you arrange them?

Flags: needinfo?(richard.marti) → needinfo?(alessandro)

Those strings might be too long to stay in 2 columns, and we might have issues with l10n if we try to arrange them.

What if we update the 2 richlistbox to behave the same?
The first list has a minheight attribute, while the second has a style="min-height: 100px;" attribute.

I think we should have both with the style="min-height: 100px;".
Also, the scrollbar appears for me if I have more than 1 rule.

Flags: needinfo?(alessandro)

I added the minheight to the <hbox> instead of the <richlistbox> because I've got a scrollbar when the dialog had the minimal height.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9104762 - Flags: review?(alessandro)
Comment on attachment 9104762 [details] [diff] [review]
1590666-filterEditor-height.patch

Review of attachment 9104762 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. r+
Attachment #9104762 - Flags: review?(alessandro) → review+
Attachment #9104762 - Flags: approval-comm-beta?
Attachment #9104835 - Flags: approval-comm-esr68?
Attachment #9104762 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9104762 [details] [diff] [review]
1590666-filterEditor-height.patch

Review of attachment 9104762 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/base/search/content/searchTerm.inc.xul
@@ +11,5 @@
>              <radio value="matchAll" id="matchAllItem" label="&matchAllMsgs.label;"
>                     accesskey="&matchAllMsgs.accesskey;"/>
>            </radiogroup>
>  
> +          <hbox flex="1" minheight="100px">

Should that be 100 instead of 100px? It's XUL, not CSS.
Flags: needinfo?(richard.marti)

Right, but it still worked. :-/

Flags: needinfo?(richard.marti)

Well, I'll land it without the "px".

Fixed the patch to avoid forgetting it.

Attachment #9104835 - Attachment is obsolete: true
Attachment #9104835 - Flags: approval-comm-esr68?
Attachment #9104844 - Flags: approval-comm-esr68+
Target Milestone: --- → Thunderbird 72.0

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/152effdcd7b1
Give the searchTerm list a minheight in filter editor. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.