If error pages are enabled, bookmark search will return the error page as a result

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: mozbug, Assigned: bugs)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2002072322 trunk linux.

Enable error page instead of dialog with this pref : 
browser.xul.error_pages.enabled (see bug 28586).
Type an non-existing hostname as http://nltnbzoreznglnhlbsnhldsfgb.com/
The error page comes up.

Do a bookmark search for location contain a substring of the previous url (e.g.
"glnhl") 

Actual results:
A bookmark with no title and the chrome url of the error page is found.
(and maybe some other real bookmarks)

Expected results:
Just the real list of bookmarks.

Updated

17 years ago
Blocks: 28586
This is basically a duplicate of bug 157004.
to be clear - this is the search in bookmarks|bookmarks manager, tools|search
bookmarks, correct?

I can't seem to reproduce that on current cvs trunk... (with the bug 157004
patch in case that matters)
Product: Browser → Seamonkey
(Reporter)

Comment 3

14 years ago
I couldn't reproduce this bug in neither Mozilla nor Firefox.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
No longer blocks: 28586
You need to log in before you can comment on or make changes to this bug.