Closed Bug 1590747 Opened 3 months ago Closed 3 months ago

Crash in [@ mozilla::dom::ClientHandle::Control]

Categories

(Core :: DOM: Service Workers, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1590748
Tracking Status
firefox72 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-414769b3-8dff-4802-881a-555e10191023.

Seen while looking at nightly crash stats - crashes started in 20191023094816: https://bit.ly/2o9H6wI. Windows and macOS so far.

MOZ_RELEASE_ASSERT(ClientMatchPrincipalInfo(mClientInfo.PrincipalInfo(), aServiceWorker.PrincipalInfo()))

Possible regression range based on build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=47d7c18620c845c3a42610fea5468ccc50889bae&tochange=ad7a152bc66c0d411a6fb0b210d675abed9693c7

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::ClientHandle::Control dom/clients/manager/ClientHandle.cpp:110
1 xul.dll class RefPtr<mozilla::MozPromise<bool, nsresult, 1> > mozilla::dom::ServiceWorkerManager::StartControllingClient dom/serviceworkers/ServiceWorkerManager.cpp:433
2 xul.dll void mozilla::dom::ServiceWorkerManager::DispatchFetchEvent dom/serviceworkers/ServiceWorkerManager.cpp:2106
3 xul.dll mozilla::dom::ServiceWorkerInterceptController::ChannelIntercepted dom/serviceworkers/ServiceWorkerInterceptController.cpp:72
4 xul.dll void mozilla::net::InterceptedHttpChannel::AsyncOpenInternal netwerk/protocol/http/InterceptedHttpChannel.cpp:149
5 xul.dll nsresult mozilla::net::InterceptedHttpChannel::AsyncOpen netwerk/protocol/http/InterceptedHttpChannel.cpp:542
6 xul.dll nsresult mozilla::net::nsHttpChannel::OpenRedirectChannel netwerk/protocol/http/nsHttpChannel.cpp:3238
7 xul.dll nsresult mozilla::net::nsHttpChannel::ContinueAsyncRedirectChannelToURI netwerk/protocol/http/nsHttpChannel.cpp:3206
8 xul.dll mozilla::net::nsHttpChannel::OnRedirectVerifyCallback netwerk/protocol/http/nsHttpChannel.cpp:9224
9 xul.dll nsresult mozilla::net::nsAsyncVerifyRedirectCallbackEvent::Run netwerk/base/nsAsyncRedirectVerifyHelper.cpp:40

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1590748
You need to log in before you can comment on or make changes to this bug.