Closed Bug 1590851 Opened 1 year ago Closed 1 year ago

Customizing menu toolbar - buttons can get lost behind Min/MaxClose buttons

Categories

(Thunderbird :: Toolbars and Tabs, defect)

x86_64
Windows 10
defect
Not set
minor

Tracking

(thunderbird_esr6870+ fixed, thunderbird71 fixed, thunderbird72 fixed)

VERIFIED FIXED
Thunderbird 72.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird71 --- fixed
thunderbird72 --- fixed

People

(Reporter: tanstaafl, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Installed the new 68.2 x64, looking forward to starting afresh.

Renamed old profile (both Roaming and Local), and let TB create a fresh new profile.

Started customizing the toolbars

Actual results:

I removed the WhiteSpace from the Menu Toolbar, then added the Hamburger menu top it on the right side.

The button got 'lost' (I could still barely see it), but I couldn't get to it.

Had to 'Restore Default Set' to recover

Expected results:

Either the Min/Max/Close buttons should be considered unusable space, or they should be considered actual buttons that take up space on the toolbar, so no other button can get lost behind them.

Severity: normal → minor
OS: Unspecified → Windows 10
Priority: -- → P5
Hardware: Unspecified → x86_64

Please attach a (small) screenshot.

No screenshot needed. I know whats the problem.

Thanks Richard., was just getting ready to create a new profile really quick to provide the screenshot...

The titlebar-placeholder was hidden on too many OS versions. It should only hide on Windows 7 Aero where the menu bar is placed below the tabs.

Assignee: nobody → richard.marti
Attachment #9104411 - Flags: review?(jorgk)
Attachment #9104411 - Flags: approval-comm-esr68?
Attachment #9104411 - Flags: approval-comm-beta?

No screenshot needed. I know what's the problem.

Great ;-) - I don't so what am I reviewing here?

OK, looks like when you draw the tabs into the titlebar and then customise the menu, the area covers the maximise/mimimise buttons.

Correct. It's already visible that the white rectangle (the flex spacer) goes behind the caption buttons. With patch no more.

Comment on attachment 9104411 [details] [diff] [review]
1590851-hide-titlebar-placeholder.patch

WFM on Windows 10. Thanks.
Attachment #9104411 - Flags: review?(jorgk)
Attachment #9104411 - Flags: review+
Attachment #9104411 - Flags: approval-comm-esr68?
Attachment #9104411 - Flags: approval-comm-esr68+
Attachment #9104411 - Flags: approval-comm-beta?
Attachment #9104411 - Flags: approval-comm-beta+

Wow... that was fast guys...

Thanks!

Priority: P5 → --

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d0a31f27b32e
Hide the titlebar-placeholder in the menu bar only under Windows 7 Aero. r=jorgk DONTBUILD

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 72.0

Working in my TB 68.2.1 build.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.