RFE: remember View|Show/Hide|Message Pane on/off setting upon closing mail/news

RESOLVED DUPLICATE of bug 203289

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 203289
16 years ago
13 years ago

People

(Reporter: Oscar van Vliet, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; nl-NL; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I would like to see that you can switch from message to message without having
to view it immediately. Currently, clicking on a message once brings it up in
the preview pane (and also marks it as 'read'). My big problem is that there is
no way of selecting the message (for deletion or something) without opening it.
That sucks for messages with many pictures and spam and also for potential
virus-containing email (I love you?).

Turning off the preview pane by clicking on the horizontal seperator seems to
work (I hope it doesn't still get rendered in the background) but this setup is
apparently not kept in the prefs and next time you start Mozilla, the preview
pane looks the same as always.

I can suggest two fixes for this:
A - Make an option (also in preferences) that adds a 2-pane option to the
mailnews window, turning off the preview pane and requiring you to fully open a
message to see it.
B - Switch to a new message in the preview pane only when it is double clicked.
This will need some indication style feature as to what message is currently
being displayed. It would also come into conflict with the existing double click
-> full message window system.

I would prefer the first. This relates to bug 75866 and bug 141332, both dealing
with preview marking as 'read.' If there is already a hidden pref to disable the
preview pane, let me know.

Reproducible: Always
Steps to Reproduce:
1. Open Mailnews
2. Click once on a message title or use an arrow key to select a new one
3. 

Actual Results:  I can see the message.

Expected Results:  Not show the message until I explicitly told it to.

Rating this bug is difficult. It could be an RFE, but there are potential
security implications. I'll just rate it minor for now since there seems to be a
workaround but it is not very convenient.

Comment 1

16 years ago
On Linux, i simply right-click a message when i wish to get the context menu but
do not want to mark it as read or display it.

Comment 2

16 years ago
forgot: After right-clicking, i can select as many messages i wish with
keyboard, without the messages displaying content. I have to left-click a
message again in order to make them display on selection. All in all: WFM.
Resize the email-view so that it's 0px high (ie, drag the splitter all the way
down). Your emails will then not be marked as read when clicked on, and you have
to doubleclick to read them (or drag the splitter back up).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
Again, use View|Show/Hide|Message Pane == OFF/unchecked (either that or Click on
the grippy to Snap the message pane shut, whereas dragging message pane splitter
is not as reliable to fully close the message pane) or use right-click for
context menu item without loading message. Verified worksforme.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
Thanks for the quick replies. Actually, dragging the email view to 0px is not a
satisfactory solution, because it pops open the next time you start Mozilla.
The same problem seems to afflict the View|Show/Hide|Message Pane settings.

I changed the summary to an RFE and reopened.

Severity: minor → enhancement
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: No way to select messages without (pre)viewing them → RFE: remember View|Show/Hide|Message Pane on/off setting upon closing mail/news

Comment 6

16 years ago
This is a painful bug for a UCE concious fool likemyself.

Oddly enough in order to disable the message pane during a session I must
_twice_ select view->show/hide->message pane as the first time has no effect
(reproducible every time in 2002100808).

Comment 7

16 years ago
Not that I can change it but how is this an enhancement - there is a menu option
to disable the message [preview] pane it just doesn't work. I would've suggested
normal even though within my own little world it's big.

My apologies if I've misread or misinterpreted.
(Reporter)

Comment 8

16 years ago
I made this an enhancement because turning it off works. It just doesn't
remember that it should stay turned off.

But the difference is rather thin. If nobody objects to turning this one into
Normal, I'd be happy to change it.

Comment 9

15 years ago
The setting for this pane-hiding is in fact maintained, if using the default 
3-pane mail layout.  With the alternate layout (wide message pane across the 
entire bottom of the window), the setting is maintained but starting Mail News, 
the setting is not abided by.  (This failure to abide by the setting results in 
the problem described by Ram Moskovitz in comment 6.)

I am duping this to that, only because it's a more direct explanation of the 
problem.

*** This bug has been marked as a duplicate of 203289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.