line breaking on ' after link with .

VERIFIED FIXED in M13

Status

()

P2
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: ftang)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

DESCRIPTION:  Currently line breaks are allowed before an ' (apostrophe) that
immediately (with no space) follows an inline element containing a ".", for
example, you are breaking (in the above URL):

<a href="http://www.mozilla.org">mozilla.org</a>'s

as:

mozilla.org
's

when the window is an appropriate width.  This occurs with other inline
elements, such as SPAN, but does not happen if there is no inline element.

STEPS TO REPRODUCE:
 * Load test case (to be attached)
 * make window size so that the lines barely have to be broken.

ACTUAL RESULTS:
 * The word mozilla.org's is broken at the ' in the first and fourth case.  The
cases are as follows:
    1) <a>mozilla.org</a>'s
    2) <a>mozillaorg</a>'s
    3) mozilla.org's
    4) <span>mozilla.org</span>'s

EXPECTED RESULTS:
 * The entire word mozilla.org's should be on the second line in all 4 cases.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-08-08-M11

ADDITIONAL INFORMATION:

I would assume this is a bug, although I don't know if Unicode specifies line
breaking, and if so, what it says.  Perhaps it's worth checking, though.
Created attachment 2047 [details]
test case described in bug
Created attachment 2048 [details]
screenshot (PNG) of test case, showing bug
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Updated

19 years ago
Hardware: PC → All
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M13
(Assignee)

Comment 3

19 years ago
I try our nsILineBreaker again and I think the bug is not inside nsILineBreaker.
I think the bug is inside nsTextFrame.cpp or other code which call the
nsTextTransformer
(Assignee)

Updated

19 years ago
Priority: P3 → P2
(Assignee)

Comment 4

19 years ago
Created attachment 4218 [details]
test case with bigger font size
(Assignee)

Comment 5

19 years ago
The problem actually have nothing to deal with ' . The problem is related to
'.'(period) . That is why if there are no . between mozilla and org it will work
fine. Fix check in 1.20 of nsJISx4501LineBreaker.cpp
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
I verified this in 2000020808 Win32, 2000020809 Linux, and 2000020410 Mac build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.