some anchors' boxes are garbled on hover or selection

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
--
minor
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Dave, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020723
BuildID:    2002072308

I am not sure _what_ component this belongs to, so I'll just give it to browser
general.

This page has two links a short way down:
"Respond to Joseph J. Sabia's recent columns." and "Be notified when a new
column is added."

When I hover over or select either link (without even hovering over the link),
some strange things happen.

Reproducible: Always
Steps to Reproduce:
1.  Load the example URL
2.  hover over one or both of the links referred to above
3.  reload the page
4.  select one or both of the links referred to above (begin your selection
outside of and avoid hovering over the link you wish to observe behaving
strangely to avoid a hover event confusing the situation)

Actual Results:  - After step 2, the text in the anchor is not visible; instead,
the text's box is filled with garbage (staticky-looking graphical randomness). 
Moving the mouse out from over the link does not fix it.
- After step 3, the text looks normal again (switching tabs or windows, or in
any way hiding the affected area and bringing it back into view fixes the problem)
- After step 4, the anchor's box is once again garbled.

Expected Results:  Clearly, we shouldn't see apparently random garbage where
there's supposed to be text.

I am reasonably certain this problem has appeared since build 20020718something
(the last build I used before this one); I'm sure I would have noticed it if it
had been a problem then as I visit this site daily.

Interestingly, when I copied the source of the page to a local file and put in a
base href tag, the problem did _not_ show up.  I wonder what that's all about.
looks like more plugin painting oddness..
Assignee: Matti → kmcclusk
Component: Browser-General → GFX Compositor
QA Contact: asa → petersen

Comment 2

16 years ago
not only anchor boxes:
bring up flash context menu on headline
dismiss it (by selecint "show all" if y ou have to)
Result: The text below the flash is garbled/nullcolor

Comment 3

16 years ago
WFM (Flash 6, Windows 2000, 072908).

Comment 4

16 years ago
Actually: selecting the text "The Cornell Review: No Shades of Gray" (which is
the top story between two grey lines) will cause "instant garbage".
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.

Comment 6

15 years ago
WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604
Shockwave Flash NPSWF32.dll 6.0 r79
Shockwave for Director np32dsw.dll 8.5.1
(Reporter)

Comment 7

15 years ago
I agree.  Can't reproduce it anymore.  Just ... went away, I guess.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.