Closed Bug 1591081 Opened 5 months ago Closed 5 months ago

Unable to Sign In to ebay

Categories

(Firefox :: Untriaged, defect)

70 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: colin.templeman, Unassigned)

References

Details

Attachments

(2 files)

Attached image ebay_login_FF_70.jpg

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Navigate to https://www.ebay.co.uk/, select "Sign In" at the top left of the page. Enter user credentials.

Actual results:

When credentials are entered (whether by built-in password manager or manually) the large "Sign In" button remains greyed-out and unselectable, leaving the user unable to login.

Expected results:

When credentials are entered (whether by built-in password manager or manually) the large "Sign In" button is blue and selectable allowing the user to login to the ebay site.

Note 1:
I have just received the update to Firefox 70.0. This website worked perfectly fine with Firefox versions prior to this.

Note 2:
I have tested the reported website working with Chromium 76.0, Tor Browser (based on Mozilla Firefox v.60.9.0esr and v.68.2.0esr), GNOME Web 3.32.2 (based on WebkitGTK) all which behave as expected. (Please see screenshot attachments).

Note 3:
I have of course tried disabling all plugins etc as a matter of course

Here is the same page working as expected in Chromium 76.0

Because this is Firefox 70.0 specific and with the new functionality added, I did not report this on https://webcompat.com/ as I don't believe this is a standards compatibility issue.

Also fails on Internet banking login (blank page this time except for cookie warning footer) https://bank.co-operativebank.co.uk/CB/p

OK. Time was short today and my usual approach prevented full diagnostics before I submitted this report. This evening has been better.

My existing profile which has worked without issue since FF 52 (when a full refresh was necessary) just did not work with the sites I cited (plus a couple of others) once FF 70 was rolled out over the top. So I tried a full refresh again (copying over settings), re-installed my exiting add-ons and custom prefs.js tweaks and ..... what do you know? For reasons I cannot fathom everything behaves as expected again.

There could well be legacy issues with FF 70 overwriting older established profiles but a full profile refresh restores functionality. I'll leave this open for now for anyone experiencing such problems but I'm surmising this isn't (and hence won't be accepted as) a core product issue.

Hi Colin,

Thanks for ALL the details. Do you perhaps happen to have the Kapersky antivirus? Because if so, this is a duplicate of this bug: 1591374. On my end, I've tried reproducing this bug on FF 70 on MacOS Catalina (10.15) but don't get the error.

Regards, Flor.

Flags: needinfo?(colin.templeman)

Hi Florencia,
Thank you for your comments. Having read through the fault you linked to it does sound remarkably similar in effect. However I don't use Kapersky antivirus and likely wouldn't even if they did provide a package for Xubuntu Linux :)

I found this latest development frustrating because I experienced absolutely no issues upgrading to every release with my existing profile since Firefox 52 (Firefox 52 you may recall deprecated NPAPI plugins and because of unresolvable issues continuing with my older profile, I was obliged to start again afresh). Prior to FF52 I used the same profile since..... well probably when Firefox and Thunderbird were spun off as separate projects from Mozilla!

Is it confirmed to be javascript injection by Kapersky? Only if I've read this right in bug: 1591374 Jan Varga is now investigating the storage changes. I don't have time right now but I can restore my old profile and test on https://firefox-storage-test.glitch.me/ and report back.

Flags: needinfo?(colin.templeman)

Hi Colin,

I believe that if you install FF69 and use the same profile as always, your settings will be restored, meaning that you won't have to do much to have your settings back. This is a problem specific to the latest version and is being investigated by Jan Varga, as you mentioned. All help is appreciated so if you can add info to the 1591374's chain, it'd be appreciated. But since it's a very recent bug, no solution has been found yet (to my knowledge). Thanks so much for your patience!

Software updates are applied automatically once the newer packages enter the repos. I could regress manually but with my new profile already in place, there's little point from my perspective.

I do have my other profile archived however, so I can test any proposed fixes for this issue against that.

Colin, try "Comodo IceDragon" as a backup Firefox browser - it is Firefox under the hood: https://icedragon.comodo.com/

Hi Collin,

Meanwhile, for your comfort, I believe you can fix this by following the instructions depicted here: https://support.mozilla.org/en-US/kb/some-pages-or-page-elements-fail-load-after-updating and then doing a refresh: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

If you want more details, you can see the developments made on bugs 1591374 and 1591547.

Regards, Flor.

Depends on: 1592136

Hi Colin,

Has your issue been fixed with this tip? Regardless, the latest FF version should've fixed this. I'll proceed to close the bug but feel free to reopen it or leave a comment if you don't agree.

Regards, Flor.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.