Problem maximizing windows on dual-monitor systems

RESOLVED DUPLICATE of bug 161249

Status

SeaMonkey
UI Design
--
minor
RESOLVED DUPLICATE of bug 161249
16 years ago
9 years ago

People

(Reporter: Todd Fraser, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X
Bug Flags:
blocking1.5b -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

There is a problem Maximizing a window on 2 head Systems. With Different
Resulutions.  When Maximize it hit The Skin doesent refresh and the window goes
to the size of the lower res monitor but the skin gets broken up with white
blotches.

Reproducible: Always
Steps to Reproduce:
1. (With Mirroring Off) Open Mozzila and it is on the first Display (lower
resulution)
2. Maximize the window
3. Drag the Window Completly into the other screen.
4. Click Maximize

Actual Results:  The WebPage display clears and the Window dosent change size. 
The Skin sometimes vanishes partly to but the Icons reapear.

Expected Results:  Maximize to fit the or at least shrink to a non maximized
form so when you hit maximize again it fills the screen on the second display.

The Workaround is to resize the window and make it a littler bigger then the old
res and hit maximize.

Comment 1

16 years ago
-> GUI features (like bug 95740)
Assignee: sgehani → blaker
Component: XP Apps → XP Apps: GUI Features

Comment 2

15 years ago
Todd, can you still reproduce this problem using a current nightly build?
Summary: Resizing Problem one 2 Monitor Display → Problem maximizing windows on dual-monitor systems

Comment 3

15 years ago
I have amazingly a similar problem under Windows XP Home (Japanese) version with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030709.

I have two monitors, which are both actually at 1024x768.  When Mozilla is
full-sized on Display 2, the menu items do not appear under the actual menu, but
rather shifted towards the left of the menu, and the helper text for URIs is
positioned between display 1 and 2 dimensions.

This looks really messed up.  I am running this from my little Sony VIAO
Picturebook.  It is actually quite common to use dual display system with
laptops, both on the Windows OS as well as Mac OS.  This looks really really
bad.  It's hard to navigate the menu items and other widgets.

The skins however look fine.

Updated

15 years ago
Flags: blocking1.5b+

Comment 4

14 years ago
darknerd2k: only Mozilla drivers can set (+) blocking flags.  you can nominate
(?) the bug for consideration.
Flags: blocking1.5b+

Updated

14 years ago
Flags: blocking1.5b?
Flags: blocking1.5a?

Comment 5

14 years ago
mozilla1.5a released. unsetting blocking request.
Flags: blocking1.5a?

Updated

14 years ago
Flags: blocking1.5b? → blocking1.5b-

Comment 6

14 years ago
OK.  Setting ? for 1.5b
Flags: blocking1.5b- → blocking1.5b?

Comment 7

14 years ago
Oops.  I didn't review message that Asa Dotzler denied request for blocking 1.5b
for dual-monitor bugs.  Chaing flag back to -.
Flags: blocking1.5b? → blocking1.5b-

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 120314 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 9

14 years ago
oops, wrong tab, sorry :(
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 10

14 years ago
confirming. following the steps in comment 0, the window just doesn't change
size. resizing the window and then maximizing actually resizes the window.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030916
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

14 years ago
I'm pretty sure this has the same root cause as bug 161249, which, although
older, has more info in it, so duping.

*** This bug has been marked as a duplicate of 161249 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.