deleted messages get UNdeleted when being focused

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Ulrich Hahn, Unassigned)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Precondition: IMAP account configured to keep deleted messages as "marked deleted"

Lets begin with the good case:
Choose one message, press delete - the red cross appears and the cursor moves
down. Press delete again: the next message is crossed and so on. (Prepare about
5 messages like this now.)

Now the bad details:
Move up one message with the cursor key. The message marked deleted before gets
undeleted again. SOMETIMES! 
More bad details:
Move up more quickly (e.g. 3 positions): only the message being displayed after
this gets undeleted. Well - delete it again: the cursor moves down and another
message gets undeleted. 

This is best seen with the imap.web.de server - but still not everytime.
Positioning the cursor with the mouse does NOT undelete.

Updated

16 years ago
QA Contact: olgam → huang

Comment 1

16 years ago
I cannot reproduce this problem if just use mouse/cursor.
What kind of the IMAP Server are you connecting with?
Also, do you know after you select the "delete" button again for Marked as
delete mode, it will toggle "mark as delete" message to "undelete" again....this
is because of fix of bug 59694......

I am thinking this bug should be invalid since that is works as design unless
you are encountering interop bug....
Assignee: sspitzer → naving
(Reporter)

Comment 2

16 years ago
There are some more circumstances worth mentioning.

a) The described behaviour seems to be limited to certain imap servers. One of
them accessible worldwide is imap.web.de allowing reading accounts of
freemail.web.de.

b) Other imap server versions, e.g. imap-2001a, version "IMAP4rev1 2001.315" do
not show the effect. But perhaps only because I have local access which does not
suffer from long delays?

c) Once the strange undelete bahaviour has started in one folder, it will
continue until program close with all folders of this imap account. Folders of
other imap accounts keep working properly.

d) The effect is _cross-platform_. I have it on a quite regular basis on MacOS9,
RH-Linux and NT4. Latest version here is Build ID: 2002080419.

Comment 3

14 years ago
Ulrich: Did/do you still see this problem?
Product: Browser → Seamonkey
WFM:Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050317
Ulrich: is this still a problem with a Current Build ?

Comment 5

13 years ago
1 year no response so I'll marking this as WFM due to the last comment. Feel
free to reopen if you can reproduce the problem with current trunk builds.
Assignee: naving → mail
QA Contact: huang

Comment 6

13 years ago
1 year no response so I'll marking this as WFM due to the last comment. Feel
free to reopen if you can reproduce the problem with current trunk builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.