Closed Bug 1591332 Opened 4 months ago Closed 3 months ago

A lot of webpages not working any longer since update to FF70

Categories

(Core :: Storage: localStorage & sessionStorage, defect)

70 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1591374
Tracking Status
firefox70 --- affected

People

(Reporter: ulli.conrad, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Just tow examples www.telepolis.de and https://www.elster.de/eportal/login/softpse

Actual results:

On www.telepolis no pictures are displayed any longer
On Elster Certifacte files can't be opened any longer

Expected results:

This happens since update from 69.0.3 to v70.0, please fix it

One more: The login button on https://accounts.google.com/signin/v2/identifier doesn't work any longer

EBay login button grayed out, not working any longer, see image

Attached image EBay login.jpg

Additional info: Doesn't work in safe mode too. But everythings seems to work fine in a new private window...

I'm investigating the issue and I'll send more information soon. https://firefox-storage-test.glitch.me reports "Investigating... If this doesn't go away, things are unexpectedly broken." because even LocalStorage database for that site seems to be corrupted and script.js doesn't handle that currently.
For now, you can can fallback to the old LocalStorage implementation by changing "dom.storage.next_gen" preference to "false".

Thank you very much, does it as a workaround. But of course program update shouldn't corrput LocalStorage database... Discovered same effect on two other computers too.

I'm sorry, but this new implementation was heavily tested during 3 beta cycles (68, 69, 70) and we didn't get bug reports like this IIRC.
BTW, do you have Kaspersky Anti-Virus installed?

No, Sophos running as AV

I cannot seem to reproduce this issue, nor have I seen it before, so I can't confirm it, but I am setting its component as (Toolkit) Storage. Jan Varga, is this a correct component?
I would like to reproduce when more information on how to do it is provided. NI me if further testing is needed.

Component: Untriaged → Storage
Flags: needinfo?(jvarga)
Product: Firefox → Toolkit
Component: Storage → DOM: Web Storage
Product: Toolkit → Core

This should be fixed by disabling new LocalStorage implementation in 70.0.1

Flags: needinfo?(jvarga)
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1591374
You need to log in before you can comment on or make changes to this bug.