Closed Bug 1591370 Opened 4 months ago Closed 4 months ago

Since update to 70, many sites can no longer load main window (possibly WebGL related?)

Categories

(Firefox :: Untriaged, defect)

70 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1591374
Webcompat Priority ?
Tracking Status
firefox69 --- unaffected
firefox70 + fixed
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: cscott, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Try to view Plex desktop via app.plex.tv
Try to upload a video to YouTube
Try to view Facebook
Try to play WebGL game such as Diggy's Adventure

Please note this started happening immediately after I updated to version 70. Please not also that this problem does not occur in Microsoft Edge (I haven't tried Chrome, because I don't have it installed).

Actual results:

Plex: Logo appears and then nothing happens.
YouTube: Upload window displays "Loading..." then nothing happens.
Facebook: Menu bars appear but content area is blank and nothing happens. Clicking on anything on the menu bar does nothing.
WebGL Game: Game loads then starts loading again and immediately displays "Error. Restart Game". Restarting does the same thing. Flash version seems to work fine.

Expected results:

Plex: Should briefly display the logo and then prompt me to choose a User.
YouTube: Upload window should briefly display "Loading..." then display option to drop file to upload.
Facebook: Content area should display timeline.
WebGL Game: Should load and then display the game contents.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Webcompat Priority: --- → ?
Component: Canvas: WebGL → Untriaged
Product: Core → Firefox
Attached image error.png

Hi,

I got an error on Diggy. Is this the error you're getting?

Flags: needinfo?(cscott)
Flags: needinfo?(cscott)
Comment on attachment 9104352 [details]
ErrorMessage-2019-10-25_18-03-18.jpg

Here's the error I'm getting.

At first I thought it was an error with that site, but the problems with Plex, YouTube, and Facebook suggest that it's something else, and since it started immediately after installing the Firefox 70 update (and doesn't happen in other browsers), that seems to be the most likely culprit.

(In reply to Emma Humphries, Bugmaster ☕️🎸🧞‍♀️✨ (she/her) [:emceeaich] (UTC-8) needinfo? me from comment #4)

Also, do you have Kapersky installed?

Sorry, I don't know what that is.

Just uninstalled Firefox version 70 and reinstalled version 69 and the problems went away. Copied everything over from my old profile (passwords, bookmarks, etc) and still not having the problem. Whatever is causing this, it definitely seems to be specific to version 70.

FYI: Before reverting, I also tried running Firefox in safe mode (no extensions and add-ons) and I was still having the problem.

could you try to come with a regression range for when the problem first appeared with the help of the tool at https://mozilla.github.io/mozregression/ pointing it to the affected profile?

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

I'll track this for now but I'm betting it is a duplicate of 1591374.
cScott, if you want to help diagnose the issue, I wonder if you could copy your profile and open it in 70 again, see if the problem occurs, then set the preference described here to false, https://support.mozilla.org/en-US/kb/some-pages-or-page-elements-fail-load-after-updating and test again.

Flags: needinfo?(cscott)

After looking at that link, I suspect you may be right, although if it's something in the profile, shouldn't Safe Mode have worked correctly? (It didn't)

I'm happy to try to help diagnose the problem, but if I go back to 70, follow those instructions, and it doesn't work, is there an easier way to revert back to 69? Trying to get my passwords, bookmarks, and such back was a bit of a pain, and it wouldn't let me restore my settings at all, so I had to go through and try to set them all manually from memory.

Flags: needinfo?(cscott)

That's ok, if it's confusing, I don't want you to risk your profile. Pretty sure this is a duplicate issue.

This issue should now be fixed in 70.0.1.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1591374
You need to log in before you can comment on or make changes to this bug.