If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 153815
15 years ago
13 years ago

People

(Reporter: guanxi, Assigned: Matti)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
eBay crashes Moz after browsing just a few pages.
I'm using 1.1b (2002072204)

TB IDs:
  8628605G
  8628802M
  8629058H
  8629751H
  8629979Z
  8630146H
  8630692Q

It's easy to duplicate:
 1)  Load ebay.com
 2)  Click something under "Categories" on the left.  Click a subcategory.
 3)  Browse around or search.
 4)  After loading ~6 pages max., it crashes every time.

I've duplicated it in Compters | PC & Apple software | PC business software, and
in Photo | Film Camera | 35mm SLR.  I've done it browsing categories, and once
when I clicked the Search button.


MY CONFIG:
Originally, I was blocking cookies from eBay and had a few items disabled under
Advanced | Scripts & Plugins | Allow scripts to:.  I've enabled all cookies,
deselected 'ask me before storing a cookie' and enabled all scripting (except in
mail&news).  I exited and reloaded Moz (quicklaunch disabled), and got the same
result.

I unzipped the 1.1b zipfile to install and created a brand new profile.  I
haven't installed any plugins.

Updated

15 years ago
Keywords: crash

Comment 1

15 years ago
I have a similar problem.  As soon as I open www.ebay.com, Mozilla uses 99% of
my CPU.  Closing ebay returns the CPU usage to normal.  
I am using Build 2002072304 / Win NT4.0 SP6.  
It didn't crash on me, but I got the same results as Ed. Mozilla uses ~95% CPU
when I'm on eBay. Closing eBay returns the CPU usage to normal levels.
(Assignee)

Comment 3

15 years ago
*** Bug 159196 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

15 years ago
eBay CPU usage is normal for me.  Like every site, it spikes up to the  ~95%
when loading, but quickly drops.  The front page uses more CPU, but I assume
it's that scrolling text.

Moz 1.1b / Win2K / PII-366

Comment 5

15 years ago
Same issue here, crashes at ebay every time. Solid everywhere else.
Currently using 2002072104, has been a problem since 1.0.

Comment 6

15 years ago
More info:

From the VS debugger:
Unhandled exception at 0x00000000 in mozilla.exe: 0xC0000005: Access violation
reading location 0x0000014c.

From the details.txt (will attach file if you want it):
 Contents of the Stack

[   0] 18 00 00 00 08 00 00 00 F8 FF 12 00 08 00 00 00 [................]
[  10] 4A 75 40 00 00 00 00 00                         [Ju@.....]

 Event Description
   32-bit Windows exception

 Event Type
            1 (0x00000001)
 Processor Exception
   3221225477 (0xC0000005)

Comment 7

15 years ago
   Based on the stack from incident 8630692 (below), I would say this is a dupe
of bug 153815.  
   Reporter, please follow that bug (you will be added to the cc list). The
developers will be eager to verify that it no longer crashes after the fix goes in.


Product ID MozillaTrunk
Build ID 2002072204
Operating System Windows NT 5.0 build 2195
URL visited ebay.com
User Comments Repeat of 8628605G, 8628802M, 8629058H, 8629751H, 8629979Z, 8630146H

Stack Trace
nsImageListener::FrameChanged
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsImageFrame.cpp, line 2390]
imgRequestProxy::FrameChanged
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 295]
imgRequest::FrameChanged
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 339]
imgContainer::Notify
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgContainer.cpp, line 460]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 352]
nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp, line 588]
nsAppShell::Run [c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp,
line 134]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1527]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1874]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1892]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903)


*** This bug has been marked as a duplicate of 153815 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.