Closed Bug 1591548 Opened 5 years ago Closed 5 years ago

Address bar sizing wrong when paste happens while window is opening

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1588953

People

(Reporter: bzbarsky, Unassigned)

References

Details

Attachments

(2 files)

Attached image Screenshot

BUILD: 2019-10-25 Mac nightly, built from https://hg.mozilla.org/mozilla-central/rev/86d60b2e96387dc818cc9fc2f9e58ef6cc1adea3

STEPS TO REPRODUCE:

  1. Start Firefox.
  2. Copy the string "https://phabricator.services.mozilla.com/D50650" so it's available to paste.
  3. In quick sequence, press Cmd+N, Cmd+L, Cmd+V

EXPECTED RESULTS: New window opens, string is pasted into its URL bar, all is normal.

ACTUAL RESULTS: The new window's URL bar is huge. See attached screenshot

RANDOM THOUGHTS: It's possible the paste happens before some sort of size computation and then we compute the wrong size because of ... something?

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Keywords: regression
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: