Closed Bug 1591575 Opened 5 months ago Closed 1 month ago

Use BaseScript accessors in js/src/debugger/Script.cpp

Categories

(Core :: JavaScript Engine, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1615710

People

(Reporter: tcampbell, Unassigned)

References

(Blocks 1 open bug)

Details

In js/src/debugger/Script.cpp we have still have code that branches on JSScript and LazyScript. Instead, we should use things like getReferentScript() to get the BaseScript and have a simpler access.

For the scope of this bug, look for calls to ensureScriptMaybeLazy() and use getReferentScript() when possible.

This will remove places that the debugger distinguishes between lazy and non-lazy scripts and makes it simpler to unify the two types.

Eg. https://searchfox.org/mozilla-central/rev/7536d7f480a7f18c941a590a2d4c5119d9f52770/js/src/debugger/Script.cpp#381-393

These concerns are generally all addressed by Bug 1615710 which changes the DebuggerScriptVariant.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1615710
You need to log in before you can comment on or make changes to this bug.