Closed Bug 1591690 Opened 3 years ago Closed 3 years ago

Permafailing browser_ext_sessions_getRecentlyClosed.js | the expected number of closed tabs/windows was found - Got 0, expected 1 when Gecko 72 merges to Beta on 2019-12-02

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
normal

Tracking

(firefox69 unaffected, firefox70 unaffected, firefox71 unaffected, firefox72 affected)

RESOLVED WORKSFORME
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- affected

People

(Reporter: nataliaCs, Unassigned)

References

(Regression)

Details

(Keywords: regression)

[Tracking Requested - why for this release]:
Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=f240cd4eb2e712483535f23a8d9175931fd388f1&searchStr=browser-chrome&selectedJob=273075326

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=273072270&repo=try&lineNumber=17131

[task 2019-10-26T11:46:28.435Z] 11:46:28 INFO - Console message: Warning: attempting to write 21328 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-10-26T11:46:28.436Z] 11:46:28 INFO - Buffered messages finished
[task 2019-10-26T11:46:28.438Z] 11:46:28 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js | the expected number of closed tabs/windows was found - Got 0, expected 1
[task 2019-10-26T11:46:28.439Z] 11:46:28 INFO - Stack trace:
[task 2019-10-26T11:46:28.439Z] 11:46:28 INFO - chrome://mochikit/content/browser-test.js:test_is:1312
[task 2019-10-26T11:46:28.440Z] 11:46:28 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_sessions.js:checkRecentlyClosed:49
[task 2019-10-26T11:46:28.441Z] 11:46:28 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js:test_sessions_get_recently_closed:62
[task 2019-10-26T11:46:28.442Z] 11:46:28 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-26T11:46:28.443Z] 11:46:28 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js | each item has a unique sessionId - Got 0, expected 1
[task 2019-10-26T11:46:28.443Z] 11:46:28 INFO - Stack trace:
[task 2019-10-26T11:46:28.444Z] 11:46:28 INFO - chrome://mochikit/content/browser-test.js:test_is:1312
[task 2019-10-26T11:46:28.444Z] 11:46:28 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_sessions.js:checkRecentlyClosed:63
[task 2019-10-26T11:46:28.444Z] 11:46:28 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/browser_ext_sessions_getRecentlyClosed.js:test_sessions_get_recently_closed:62

Might be related to Bug 1447807.
:trishul.goel any chance you could take a look? Thank you.

Flags: needinfo?(trishul.goel)

Hi Natalia,
I tried to look into this, but was unable to get any pointers.
I ran the mochitest with latest tip and was not able to get this error.

Flags: needinfo?(trishul.goel)

Hi Trishul, to reproduce you can try the following steps: https://wiki.mozilla.org/Sheriffing/How_To/Beta_simulations#TRUNK_AS_EARLY_BETA

Flags: needinfo?(trishul.goel)

By any chance does this require access to try server? as I don't have it
https://wiki.mozilla.org/ReleaseEngineering/TryServer#Try_Server

Flags: needinfo?(trishul.goel)

Trishul, if you don't have access to try we can test the patch for you on the daily beta-sims we're doing.

Flags: needinfo?(trishul.goel)

Hi Cosmin, as mentioned in #c1 I am not able to reproduce this issue.

Flags: needinfo?(trishul.goel)

Only observed with last Saturday's central-as-beta simulation.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Has Regression Range: --- → yes
Keywords: regression
You need to log in before you can comment on or make changes to this bug.