download window progress doesn't stop when saving page as text

VERIFIED FIXED

Status

Camino Graveyard
General
--
minor
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Simon Fraser)

Tracking

({polish})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
found using 2002.07.24.05 chimera bits.

0. make sure you have the "leave Open" option selected for the download window.
1. go to any web page, eg, http://mozilla.org/
2. hit cmd+S or select File > Save Page As
3. in the resulting file picker, select the format as "plain text"
4. hit Save.

results: the page is saved, but the progress meter in the download window keeps
on animating.

could this be related to the fix for bug 155334?

interestingly, if context-select "save link as" for a text file (or use
cmd+S/File > Save As when viewing a text file), i don't encounter this. (namely,
there's no option for file format.)

Comment 1

16 years ago
->sfraser
Assignee: saari → sfraser

Updated

16 years ago
Blocks: 147975
(Reporter)

Comment 2

16 years ago
this seems more polish than a blocker, since the file is saved.
Severity: normal → minor
Keywords: polish
QA Contact: winnie → sairuh
(Assignee)

Comment 3

16 years ago
Actually, we could argue that this is expected behaviour. The window is
following the setting of the 'Leave open'/'Close when done' button in the
download dialog.

I think we should hide that button for 'Save' operations, and always just close
the dialog.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

16 years ago
comment 3: on a related note, also see bug 158751.
(Assignee)

Comment 5

16 years ago
Created attachment 92607 [details] [diff] [review]
Patch to hide the 'leave open' button, and always close the progress dialog, when Saving
bueno. r=pink
(Assignee)

Comment 7

16 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
verified with 07-25 build on OS 10.1.5.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 147975
You need to log in before you can comment on or make changes to this bug.