Won't mark as "read" for Imail server

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: dj radon, Assigned: Scott MacGregor)

Tracking

({imap-interop})

Trunk
x86
Windows XP
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

Changes to the "read" status don't get updated back on the Imail server v.5. I'm
sure Imail is just doing something non-standard with IMAP commands, but Outlook
and outlook express work! Essentially, a message becomes un-bolded after I've
read it, but if I select another folder, and then select back to the original,
the read messages returns to "bold". 

Reproducible: Always
Steps to Reproduce:
1.Use an IMAP account on an IMail 6 server (email me if you need a test account)
2. Receive a new message, read it, wait until it becomes unhilighted.
3. Change folders, change back

Actual Results:  The read message is displayed in Bold again.

Expected Results:  The read message remain non-bolded

If you need an IMail account to test this, contact me. radon@kzsu.stanford.edu

Updated

16 years ago
Keywords: interop
QA Contact: huang → meehansqa

Comment 1

16 years ago
Does the message get marked read after previweing it twice? See bug 159267. This
might be a dup of that. Also an imap log might help people figure out whats
happening. See http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Comment 2

16 years ago
dj radon,

Ping! any updates? Did you try getting a log file?
(Reporter)

Comment 3

16 years ago
Created attachment 94208 [details]
Logfile illustrating Bug#159180
(Reporter)

Comment 4

16 years ago
Does not appear to be the same problem described in 159267: after previewing
twice (or any number of times) the message is still marked as unseen.

Comment 5

16 years ago
*** Bug 162879 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Should this bug be marked as new considering that there's a dup for it?

Comment 7

16 years ago
Yes - marking as NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
I also am using Imail as my imap server.  It seems I only have this problem 
when I enable "Make the messages in my Inbox available when I am working 
offline."   

Comment 9

16 years ago
This happens to me too with Mozilla 1.1, but not with every message.  Certain
messages just don't behave while others take on the Read status just fine. 
Moving the problem messages to another folder, reading them there, and then
moving them back seems to take care of it.  Other clients handle the problem
messages just fine.

My server is IMAP4rev1 v12.264

Comment 10

15 years ago
I believe the imail specific problem was fixed in 1.3 or earlier. Does anyone
still see this?

Comment 11

15 years ago
marking wfm
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.